summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-04-16 06:14:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-04-16 06:14:32 +0000
commit6243abcbe76607fbf14b87c7d9595980c75ca242 (patch)
treeac5b13323cc94655ffc577bd4f831bf3e0ce5430 /dev-python/cffi/cffi-0.6.ebuild
parentAdded missing patch. Fixes build failure in bug #466052 by Patrick Lauer. (diff)
downloadgentoo-2-6243abcbe76607fbf14b87c7d9595980c75ca242.tar.gz
gentoo-2-6243abcbe76607fbf14b87c7d9595980c75ca242.tar.bz2
gentoo-2-6243abcbe76607fbf14b87c7d9595980c75ca242.zip
Bump
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/cffi/cffi-0.6.ebuild')
-rw-r--r--dev-python/cffi/cffi-0.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/cffi/cffi-0.6.ebuild b/dev-python/cffi/cffi-0.6.ebuild
new file mode 100644
index 000000000000..78cf618f4372
--- /dev/null
+++ b/dev-python/cffi/cffi-0.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.6.ebuild,v 1.1 2013/04/16 06:14:32 patrick Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code."
+HOMEPAGE="http://cffi.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="virtual/libffi
+ dev-python/pycparser[$(python_gen_usedep python{2_6,2_7} pypy{1_9,2_0})]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/hgdistver"
+DEPEND="$REDEPEND
+ test? ( dev-python/virtualenv )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test c/ testing/ -x -v
+}
+
+python_install_all() {
+ use doc && dohtml -r doc/build/
+}