summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCorentin Chary <iksaif@gentoo.org>2012-07-17 15:10:59 +0000
committerCorentin Chary <iksaif@gentoo.org>2012-07-17 15:10:59 +0000
commit9ba9ad7a1baa9fa4c951b0a0d3fd3f79b4c1c639 (patch)
tree61ccea44aa73b798cf9c922f828a22c6e097912f /dev-python/celery
parentkombu 2.2.6 version bump. (diff)
downloadgentoo-2-9ba9ad7a1baa9fa4c951b0a0d3fd3f79b4c1c639.tar.gz
gentoo-2-9ba9ad7a1baa9fa4c951b0a0d3fd3f79b4c1c639.tar.bz2
gentoo-2-9ba9ad7a1baa9fa4c951b0a0d3fd3f79b4c1c639.zip
Bump to 2.5.5 and 3.0.1. Add examples and doc thanks to idella4.
Closes #425794 and #422661. (Portage version: 2.1.11.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/celery')
-rw-r--r--dev-python/celery/ChangeLog11
-rw-r--r--dev-python/celery/celery-2.5.3.ebuild61
-rw-r--r--dev-python/celery/celery-2.5.5.ebuild94
-rw-r--r--dev-python/celery/celery-3.0.1.ebuild91
-rw-r--r--dev-python/celery/files/celery-3.0.1-fix-setuptools-import.patch37
5 files changed, 232 insertions, 62 deletions
diff --git a/dev-python/celery/ChangeLog b/dev-python/celery/ChangeLog
index 71ecfc8c294b..f0e957e31f5f 100644
--- a/dev-python/celery/ChangeLog
+++ b/dev-python/celery/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/celery
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/ChangeLog,v 1.2 2012/07/16 08:33:58 iksaif Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/ChangeLog,v 1.3 2012/07/17 15:10:59 iksaif Exp $
+
+*celery-2.5.5 (17 Jul 2012)
+*celery-3.0.1 (17 Jul 2012)
+
+ 17 Jul 2012; Corentin Chary <iksaif@gentoo.org> +celery-2.5.5.ebuild,
+ +celery-3.0.1.ebuild, +files/celery-3.0.1-fix-setuptools-import.patch,
+ -celery-2.5.3.ebuild:
+ Bump to 2.5.5 and 3.0.1. Add examples and doc thanks to idella4. Closes
+ #425794 and #422661.
16 Jul 2012; Corentin Chary <iksaif@gentoo.org> files/celery.initd:
LICENSE variable does not reflect init script. Closes #425934.
diff --git a/dev-python/celery/celery-2.5.3.ebuild b/dev-python/celery/celery-2.5.3.ebuild
deleted file mode 100644
index 3b75bc0c6d08..000000000000
--- a/dev-python/celery/celery-2.5.3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/celery-2.5.3.ebuild,v 1.1 2012/05/30 06:45:54 iksaif Exp $
-
-EAPI="4"
-
-# Note: some tests are still broken for python3...
-# PYTHON_TESTS_RESTRICTED_ABIS="3.*"
-PYTHON_DEPEND="*:2.7"
-RESTRICT_PYTHON_ABIS="2.[4-6]"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils eutils
-
-DESCRIPTION="Celery is an open source asynchronous task queue/job queue based on distributed message passing."
-HOMEPAGE="http://celeryproject.org/ http://pypi.python.org/pypi/celery"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="sql test"
-
-# jython would need: threadpool, simplejson
-# python2.5 would need: ordereddict, test? unittest2
-# python2.6 would need: multiprocessing, test? simplejson
-RDEPEND=">=dev-python/kombu-2.1.1
- <dev-python/kombu-3.0
- sql? ( dev-python/sqlalchemy )
- dev-python/python-dateutil
- >=dev-python/anyjson-0.3.1
- dev-python/pyparsing
- "
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/mock-0.7.0
- dev-python/pyopenssl
- dev-python/nose-cover3
- dev-python/sqlalchemy
- dev-python/pymongo
- dev-python/cl
- dev-db/redis
- )
- dev-python/setuptools"
-
-src_test() {
- testing() {
- nosetests --py3where build-${PYTHON_ABI}/lib/celery/tests
- }
- python_execute_function testing
-}
-
-src_install() {
-
- distutils_src_install --install-scripts="/usr/bin"
-
- # Main celeryd init.d and conf.d
- newinitd "${FILESDIR}/celery.initd" celery
- newconfd "${FILESDIR}/celery.confd" celery
-}
diff --git a/dev-python/celery/celery-2.5.5.ebuild b/dev-python/celery/celery-2.5.5.ebuild
new file mode 100644
index 000000000000..56d5a6cc915e
--- /dev/null
+++ b/dev-python/celery/celery-2.5.5.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/celery-2.5.5.ebuild,v 1.1 2012/07/17 15:10:59 iksaif Exp $
+
+EAPI="4"
+
+# Not broken but unsupported; dev-python/redis-py doesn't
+# support python3 which is a dep in tests. pypy fails just 1 test
+PYTHON_TESTS_RESTRICTED_ABIS="3.* 2.7-pypy-*"
+PYTHON_DEPEND="*:2.7"
+RESTRICT_PYTHON_ABIS="2.[5-6]"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+DESCRIPTION="Celery is an open source asynchronous task queue/job queue based on distributed message passing."
+HOMEPAGE="http://celeryproject.org/ http://pypi.python.org/pypi/celery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples sql test"
+
+# jython would need: threadpool, simplejson
+# python2.5 would need: ordereddict, test? unittest2
+# python2.6 would need: multiprocessing, test? simplejson
+RDEPEND=">=dev-python/kombu-2.1.1
+ <dev-python/kombu-2.2.5
+ sql? ( dev-python/sqlalchemy )
+ dev-python/python-dateutil
+ >=dev-python/anyjson-0.3.1
+ dev-python/pyparsing
+ "
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/mock-0.7.0
+ dev-python/pyopenssl
+ dev-python/nose-cover3
+ dev-python/sqlalchemy
+ dev-python/pymongo
+ dev-python/cl
+ dev-python/redis-py
+ dev-db/redis
+ )
+ doc? (
+ dev-python/docutils
+ dev-python/sphinx
+ dev-python/jinja
+ dev-python/sphinxcontrib-issuetracker
+ dev-python/sqlalchemy
+ )
+ dev-python/setuptools"
+
+src_prepare() {
+ # Get tests to pass
+ # For some reason uses import pymongo.binary but system has bson.binary
+ sed -e 's:from pymongo import binary:from bson import binary:' \
+ -i celery/tests/test_backends/test_mongodb.py || die
+ sed -e 's:pymongo.binary:bson.binary:' -i celery/backends/mongodb.py || die
+}
+
+src_test() {
+ testing() {
+ nosetests --py3where build-${PYTHON_ABI}/lib/celery/tests
+ }
+ python_execute_function testing
+}
+
+src_compile() {
+ distutils_src_compile
+ dodocs() {
+ if [[ "${PYTHON_ABI}" == "2.7" ]]; then
+ mkdir docs/.build || die
+ PYTHONPATH="${S}/doc:${S}/build-${PYTHON_ABI}"/lib emake -C docs html
+ fi
+ }
+ use doc && python_execute_function dodocs
+}
+
+src_install() {
+ distutils_src_install --install-scripts="/usr/bin"
+
+ # Main celeryd init.d and conf.d
+ newinitd "${FILESDIR}/celery.initd" celery
+ newconfd "${FILESDIR}/celery.confd" celery
+
+ if use examples; then
+ insinto usr/share/doc/${P}/
+ doins -r examples
+ fi
+ use doc && dohtml -r docs/.build/html/
+}
diff --git a/dev-python/celery/celery-3.0.1.ebuild b/dev-python/celery/celery-3.0.1.ebuild
new file mode 100644
index 000000000000..91b2c0bfd03b
--- /dev/null
+++ b/dev-python/celery/celery-3.0.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/celery/celery-3.0.1.ebuild,v 1.1 2012/07/17 15:10:59 iksaif Exp $
+
+EAPI="4"
+
+# Not broken but unsupported; dev-python/redis-py doesn't
+# support python3 which is a dep in tests. pypy fails just 1 test
+PYTHON_TESTS_RESTRICTED_ABIS="3.* 2.7-pypy-*"
+PYTHON_DEPEND="*:2.7"
+RESTRICT_PYTHON_ABIS="2.[5-6]"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+DESCRIPTION="Celery is an open source asynchronous task queue/job queue based on distributed message passing."
+HOMEPAGE="http://celeryproject.org/ http://pypi.python.org/pypi/celery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples sql test"
+
+# jython would need: threadpool, simplejson
+# python2.5 would need: ordereddict, test? unittest2
+# python2.6 would need: multiprocessing, test? simplejson
+RDEPEND=">=dev-python/kombu-2.2.5
+ <dev-python/kombu-3.0
+ sql? ( dev-python/sqlalchemy )
+ dev-python/python-dateutil
+ >=dev-python/anyjson-0.3.3
+ dev-python/pyparsing
+ dev-python/billiard
+ "
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/mock-0.7.0
+ dev-python/pyopenssl
+ dev-python/nose-cover3
+ dev-python/sqlalchemy
+ dev-python/pymongo
+ dev-python/redis-py
+ dev-db/redis
+ )
+ doc? (
+ dev-python/docutils
+ dev-python/sphinx
+ dev-python/jinja
+ dev-python/sphinxcontrib-issuetracker
+ dev-python/sqlalchemy
+ )
+ dev-python/setuptools"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.0.1-fix-setuptools-import.patch"
+}
+
+src_test() {
+ testing() {
+ nosetests --py3where build-${PYTHON_ABI}/lib/${PN}/tests
+ }
+ python_execute_function testing
+}
+
+src_compile() {
+ distutils_src_compile
+ dodocs() {
+ echo "test $PYTHON_ABI"
+ if [[ "${PYTHON_ABI}" == "2.7" ]]; then
+ mkdir docs/.build || die
+ PYTHONPATH="${S}/doc:${S}/build-${PYTHON_ABI}"/lib emake -C docs html
+ fi
+ }
+ use doc && python_execute_function dodocs
+}
+
+src_install() {
+ distutils_src_install --install-scripts="/usr/bin"
+
+ # Main celeryd init.d and conf.d
+ newinitd "${FILESDIR}/celery.initd" celery
+ newconfd "${FILESDIR}/celery.confd" celery
+
+ if use examples; then
+ insinto usr/share/doc/${P}/
+ doins -r examples
+ fi
+ use doc && dohtml -r docs/.build/html/
+}
diff --git a/dev-python/celery/files/celery-3.0.1-fix-setuptools-import.patch b/dev-python/celery/files/celery-3.0.1-fix-setuptools-import.patch
new file mode 100644
index 000000000000..ca9542178f66
--- /dev/null
+++ b/dev-python/celery/files/celery-3.0.1-fix-setuptools-import.patch
@@ -0,0 +1,37 @@
+--- setup.py.orig 2012-07-17 08:31:53.346133430 +0200
++++ setup.py 2012-07-17 08:32:08.296813785 +0200
+@@ -8,6 +8,16 @@
+ raise Exception('Celery requires Python 2.5 or higher.')
+
+ try:
++ from setuptools import setup, find_packages
++ from setuptools.command.test import test
++except ImportError:
++ raise
++ from ez_setup import use_setuptools
++ use_setuptools()
++ from setuptools import setup, find_packages # noqa
++ from setuptools.command.test import test # noqa
++
++try:
+ orig_path = sys.path[:]
+ for path in (os.path.curdir, os.getcwd()):
+ if path in sys.path:
+@@ -32,17 +42,6 @@
+ except:
+ pass
+
+-
+-try:
+- from setuptools import setup, find_packages
+- from setuptools.command.test import test
+-except ImportError:
+- raise
+- from ez_setup import use_setuptools
+- use_setuptools()
+- from setuptools import setup, find_packages # noqa
+- from setuptools.command.test import test # noqa
+-
+ NAME = 'celery'
+ entrypoints = {}
+ extra = {}