summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-07-03 06:41:17 +0000
committerAli Polatel <hawking@gentoo.org>2007-07-03 06:41:17 +0000
commitc2f68a4525d7b56a12517f90ee404f77ac441217 (patch)
treece144ec41b4c3af8fcec4aa3d16b562f324a7638 /dev-python/celementtree/celementtree-1.0.5-r1.ebuild
parentremoved postrm and postinst, as they are exactly like that in elisp.eclass (m... (diff)
downloadgentoo-2-c2f68a4525d7b56a12517f90ee404f77ac441217.tar.gz
gentoo-2-c2f68a4525d7b56a12517f90ee404f77ac441217.tar.bz2
gentoo-2-c2f68a4525d7b56a12517f90ee404f77ac441217.zip
use system expat (bug 178919), fix src_test (bug 179589)
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'dev-python/celementtree/celementtree-1.0.5-r1.ebuild')
-rw-r--r--dev-python/celementtree/celementtree-1.0.5-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/celementtree/celementtree-1.0.5-r1.ebuild b/dev-python/celementtree/celementtree-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..6466cdf39a86
--- /dev/null
+++ b/dev-python/celementtree/celementtree-1.0.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/celementtree/celementtree-1.0.5-r1.ebuild,v 1.1 2007/07/03 06:41:17 hawking Exp $
+
+inherit distutils eutils
+
+MY_P="cElementTree-${PV}-20051216"
+DESCRIPTION="The cElementTree module is a C implementation of the ElementTree API"
+HOMEPAGE="http://effbot.org/zone/celementtree.htm"
+SRC_URI="http://effbot.org/downloads/${MY_P}.tar.gz"
+
+LICENSE="ElementTree"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+IUSE="doc"
+DEPEND=">=dev-lang/python-2.1.3-r1
+ >=dev-python/elementtree-1.2
+ >=dev-libs/expat-1.95.8"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-use_system_expat.patch"
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ insinto /usr/share/doc/${PF}/samples
+ doins samples/*
+ doins selftest.py
+ fi
+}
+
+src_test() {
+ PYTHONPATH="$(ls -d build/lib.*)" "${python}" selftest.py \
+ || die "tests failed"
+}