summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-05-20 16:50:29 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-05-20 16:50:29 +0000
commitc6262478ebc0e6b2c6bfe993b3593ace280bf60f (patch)
tree751b3aadc84060c0e681c42883b72fac1f6bc81f /dev-python/bottle
parentadd version 4.9.5 for 4.9.5_p01 cannot function correctly, upstream bug http:... (diff)
downloadgentoo-2-c6262478ebc0e6b2c6bfe993b3593ace280bf60f.tar.gz
gentoo-2-c6262478ebc0e6b2c6bfe993b3593ace280bf60f.tar.bz2
gentoo-2-c6262478ebc0e6b2c6bfe993b3593ace280bf60f.zip
Don't inherit eutils.eclass since it's not used, drop unnecessary dependecy on setuptools. Thanks to Arfrever for report
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/ChangeLog6
-rw-r--r--dev-python/bottle/bottle-0.10.9.ebuild8
2 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/bottle/ChangeLog b/dev-python/bottle/ChangeLog
index 0ffd4ad8de82..d730f2f0724a 100644
--- a/dev-python/bottle/ChangeLog
+++ b/dev-python/bottle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/bottle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/ChangeLog,v 1.1 2012/05/19 10:53:54 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/ChangeLog,v 1.2 2012/05/20 16:50:29 xarthisius Exp $
+
+ 20 May 2012; Kacper Kowalik <xarthisius@gentoo.org> bottle-0.10.9.ebuild:
+ Don't inherit eutils.eclass since it's not used, drop unnecessary dependecy on
+ setuptools. Thanks to Arfrever for report
*bottle-0.10.9 (19 May 2012)
diff --git a/dev-python/bottle/bottle-0.10.9.ebuild b/dev-python/bottle/bottle-0.10.9.ebuild
index e70a783ae3f2..5a73afc1d7bd 100644
--- a/dev-python/bottle/bottle-0.10.9.ebuild
+++ b/dev-python/bottle/bottle-0.10.9.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/bottle-0.10.9.ebuild,v 1.1 2012/05/19 10:53:54 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/bottle-0.10.9.ebuild,v 1.2 2012/05/20 16:50:29 xarthisius Exp $
EAPI=4
SUPPORT_PYTHON_ABIS=1
RESTRICT_PYTHON_ABIS="*-jython"
-inherit distutils eutils
+inherit distutils
DESCRIPTION="A fast and simple micro-framework for small web-applications"
HOMEPAGE="http://pypi.python.org/pypi/bottle http://bottlepy.org/"
@@ -20,8 +20,8 @@ IUSE=""
PYTHON_MODNAME=bottle.py
-RDEPEND="dev-python/simplejson"
-DEPEND="${RDEPEND} dev-python/setuptools"
+DEPEND="dev-python/simplejson"
+RDEPEND="${DEPEND}"
src_prepare() {
distutils_src_prepare