summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-07-15 04:38:04 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-07-15 04:38:04 +0000
commit8c541a89024d59671ab4db9b7574044831a7fbc7 (patch)
treea71e22503d7a76e23a9ced806d6288108f7efdb1 /dev-python/bottle
parentAdd a warning about systemd-resolved. (diff)
downloadgentoo-2-8c541a89024d59671ab4db9b7574044831a7fbc7.tar.gz
gentoo-2-8c541a89024d59671ab4db9b7574044831a7fbc7.tar.bz2
gentoo-2-8c541a89024d59671ab4db9b7574044831a7fbc7.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/ChangeLog7
-rw-r--r--dev-python/bottle/bottle-0.12.7.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/bottle/ChangeLog b/dev-python/bottle/ChangeLog
index b22ec460d442..2e591a7b9234 100644
--- a/dev-python/bottle/ChangeLog
+++ b/dev-python/bottle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/bottle
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/ChangeLog,v 1.36 2014/07/08 00:19:29 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/ChangeLog,v 1.37 2014/07/15 04:38:04 patrick Exp $
+
+*bottle-0.12.7 (15 Jul 2014)
+
+ 15 Jul 2014; Patrick Lauer <patrick@gentoo.org> +bottle-0.12.7.ebuild:
+ Bump
08 Jul 2014; Naohiro Aota <naota@gentoo.org> bottle-0.12.6.ebuild:
Add ~x86-fbsd wrt #515610
diff --git a/dev-python/bottle/bottle-0.12.7.ebuild b/dev-python/bottle/bottle-0.12.7.ebuild
new file mode 100644
index 000000000000..808969c43b1e
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/bottle-0.12.7.ebuild,v 1.1 2014/07/15 04:38:04 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="http://pypi.python.org/pypi/bottle http://bottlepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+python_prepare_all() {
+ sed -i -e '/scripts/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}