summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-08-27 07:49:34 +0000
committerTim Harder <radhermit@gentoo.org>2013-08-27 07:49:34 +0000
commit74c7acd4cac5f0b6bad31ee144181d9ba80e601c (patch)
tree3561603e066b13391f41a672de15a3f09b2c3d59 /dev-python/boto
parentVersion bump. (diff)
downloadgentoo-2-74c7acd4cac5f0b6bad31ee144181d9ba80e601c.tar.gz
gentoo-2-74c7acd4cac5f0b6bad31ee144181d9ba80e601c.tar.bz2
gentoo-2-74c7acd4cac5f0b6bad31ee144181d9ba80e601c.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/ChangeLog7
-rw-r--r--dev-python/boto/boto-2.10.0.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index 133b36d6f4a7..f51e7a2d09d2 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.66 2013/07/24 23:30:49 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.67 2013/08/27 07:49:34 radhermit Exp $
+
+*boto-2.10.0 (27 Aug 2013)
+
+ 27 Aug 2013; Tim Harder <radhermit@gentoo.org> +boto-2.10.0.ebuild:
+ Version bump.
*boto-2.9.9 (24 Jul 2013)
diff --git a/dev-python/boto/boto-2.10.0.ebuild b/dev-python/boto/boto-2.10.0.ebuild
new file mode 100644
index 000000000000..ef1d0a4d0ad6
--- /dev/null
+++ b/dev-python/boto/boto-2.10.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.10.0.ebuild,v 1.1 2013/08/27 07:49:34 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/m2crypto )"
+RDEPEND="dev-python/m2crypto"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}