summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-08-22 19:18:30 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-08-22 19:18:30 +0000
commitc0cd616b095a63bf698d90a502868a15dd6ece30 (patch)
tree7fbafff567a7eb3927e401292f7184408ec350b6 /dev-python/bonobo-python
parentnotes: 1. to accomodate kernel ebuild structure, no modules are built. (diff)
downloadgentoo-2-c0cd616b095a63bf698d90a502868a15dd6ece30.tar.gz
gentoo-2-c0cd616b095a63bf698d90a502868a15dd6ece30.tar.bz2
gentoo-2-c0cd616b095a63bf698d90a502868a15dd6ece30.zip
added bonobo-python, bonobo-wrapper for python
Diffstat (limited to 'dev-python/bonobo-python')
-rw-r--r--dev-python/bonobo-python/bonobo-python-0.2.0.ebuild33
-rw-r--r--dev-python/bonobo-python/files/digest-bonobo-python-0.2.01
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/bonobo-python/bonobo-python-0.2.0.ebuild b/dev-python/bonobo-python/bonobo-python-0.2.0.ebuild
new file mode 100644
index 000000000000..57d80ae5fc1d
--- /dev/null
+++ b/dev-python/bonobo-python/bonobo-python-0.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <micke@hallendal.net>
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bonobo-python/bonobo-python-0.2.0.ebuild,v 1.1 2001/08/22 19:18:30 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Bonobo bindings for Python"
+SRC_URI="http://theta.lajnux.nu/bonobo-python/download/${A}"
+HOMEPAGE="http://theta.lajnux.nu/bonobo-python/"
+
+DEPEND=">=x11-libs/gtk+-1.2.6
+ >=gnome-base/bonobo-1.0.0
+ >=dev-python/gnome-python-1.3.1
+ >=dev-python/orbit-python-0.3.0
+ virtual/python"
+
+src_compile() {
+ PYTHON="/usr/bin/python" try ./configure --host=${CHOST} --prefix=/usr \
+ --with-libIDL-prefix=/opt/gnome --with-orbit-prefix=/opt/gnome \
+ --with-oaf-prefix=/opt/gnome
+ try make
+}
+
+src_install() {
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog NEWS
+ dodoc README TODO
+}
+
+
+
+
diff --git a/dev-python/bonobo-python/files/digest-bonobo-python-0.2.0 b/dev-python/bonobo-python/files/digest-bonobo-python-0.2.0
new file mode 100644
index 000000000000..9926ab43a21b
--- /dev/null
+++ b/dev-python/bonobo-python/files/digest-bonobo-python-0.2.0
@@ -0,0 +1 @@
+MD5 85a2d3fc437bc1235a5a5c72b8ab6f70 bonobo-python-0.2.0.tar.gz