summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-08-19 13:18:55 +0000
committerAli Polatel <hawking@gentoo.org>2008-08-19 13:18:55 +0000
commite3d58d410b55db9d14700597d8f91ccf1dea10d1 (patch)
tree6c6e090e801798db83738f28acd18deb748de4b9 /dev-python/bicyclerepair
parentVersion bump. Added Sans Mono font. (diff)
downloadgentoo-2-e3d58d410b55db9d14700597d8f91ccf1dea10d1.tar.gz
gentoo-2-e3d58d410b55db9d14700597d8f91ccf1dea10d1.tar.bz2
gentoo-2-e3d58d410b55db9d14700597d8f91ccf1dea10d1.zip
Revbump. Added two patches to fix idle and syntax errors, thanks to René 'Necoro' Neumann, #232594.
(Portage version: -svn.wrabbit)
Diffstat (limited to 'dev-python/bicyclerepair')
-rw-r--r--dev-python/bicyclerepair/ChangeLog11
-rw-r--r--dev-python/bicyclerepair/bicyclerepair-0.9-r2.ebuild62
-rw-r--r--dev-python/bicyclerepair/files/bicyclerepair-0.9-idle.patch41
-rw-r--r--dev-python/bicyclerepair/files/bicyclerepair-0.9-invalid-syntax.patch11
4 files changed, 124 insertions, 1 deletions
diff --git a/dev-python/bicyclerepair/ChangeLog b/dev-python/bicyclerepair/ChangeLog
index e092aeea3104..a97760f3d1bb 100644
--- a/dev-python/bicyclerepair/ChangeLog
+++ b/dev-python/bicyclerepair/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/bicyclerepair
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bicyclerepair/ChangeLog,v 1.19 2008/08/19 13:13:36 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bicyclerepair/ChangeLog,v 1.20 2008/08/19 13:18:55 hawking Exp $
+
+*bicyclerepair-0.9-r2 (19 Aug 2008)
+
+ 19 Aug 2008; Ali Polatel <hawking@gentoo.org>
+ +files/bicyclerepair-0.9-idle.patch,
+ +files/bicyclerepair-0.9-invalid-syntax.patch,
+ +bicyclerepair-0.9-r2.ebuild:
+ Revbump. Added two patches to fix idle and syntax errors, thanks to René
+ 'Necoro' Neumann, #232594.
19 Aug 2008; Ali Polatel <hawking@gentoo.org> bicyclerepair-0.9-r1.ebuild:
Set PYTHON_MODNAME, compile python files properly.
diff --git a/dev-python/bicyclerepair/bicyclerepair-0.9-r2.ebuild b/dev-python/bicyclerepair/bicyclerepair-0.9-r2.ebuild
new file mode 100644
index 000000000000..bc72b4fd5f55
--- /dev/null
+++ b/dev-python/bicyclerepair/bicyclerepair-0.9-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bicyclerepair/bicyclerepair-0.9-r2.ebuild,v 1.1 2008/08/19 13:18:55 hawking Exp $
+
+inherit distutils elisp-common eutils
+
+DESCRIPTION="Bicycle Repair Man is the Python Refactoring Browser"
+HOMEPAGE="http://bicyclerepair.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bicyclerepair/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="emacs"
+
+DEPEND="virtual/python
+ emacs? ( app-emacs/pymacs
+ app-emacs/python-mode )"
+
+SITEFILE=50${PN}-gentoo.el
+PYTHON_MODNAME="bike"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # bikeemacs.py contains non-ascii characters in comments
+ sed -i -e '1s/$/\t-*- coding: latin-1 -*-/' ide-integration/bikeemacs.py
+ epatch "${FILESDIR}"/${P}-idle.patch
+ epatch "${FILESDIR}"/${P}-invalid-syntax.patch
+}
+
+src_install() {
+ distutils_src_install
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ # Enable IDLE integration if Python was compiled with tcltk.
+ config_txt="${ROOT}"/usr/lib/python${PYVER}/tools/idle/config.txt
+ if [ -f "${config_txt}" ];
+ then
+ if [ -z "`grep BicycleRepairMan_Idle ${config_txt}`" ]; then
+ elog "Appending BicycleRepairman to IDLE.."
+ echo "[BicycleRepairMan_Idle]" >> ${config_txt}
+ fi
+ else
+ elog "BicycleRepairMan won't integrate with IDLE"
+ fi
+ use emacs && elisp-site-regen
+
+ distutils_pkg_postinst
+ python_mod_optimize $(python_get_sitedir)/bikeemacs.py
+ python_mod_optimize $(python_get_sitedir)/BicycleRepairMan_Idle.py
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ python_mod_cleanup
+}
diff --git a/dev-python/bicyclerepair/files/bicyclerepair-0.9-idle.patch b/dev-python/bicyclerepair/files/bicyclerepair-0.9-idle.patch
new file mode 100644
index 000000000000..ff7e6f8d80bd
--- /dev/null
+++ b/dev-python/bicyclerepair/files/bicyclerepair-0.9-idle.patch
@@ -0,0 +1,41 @@
+=== modified file 'ide-integration/BicycleRepairMan_Idle.py'
+--- ide-integration/BicycleRepairMan_Idle.py 2008-07-21 20:08:33 +0000
++++ ide-integration/BicycleRepairMan_Idle.py 2008-07-21 20:15:02 +0000
+@@ -300,21 +300,21 @@
+ return 1
+
+
+-    def confirm_buffer_is_saved(self, editwin):
+-        if not editwin.get_saved():
+-            name = (editwin.short_title()or
+-            editwin.long_title()or
+-            "Untitled")
+-            reply = tkMessageBox.askokcancel("Bicycle Repair Man",
+-                "The buffer for %s is not saved.\n\n"%name+
+-                "Save it and continue?",
+-                master = self.editwin.text)
+-          &nbs p; self.editwin.text.focus_set()
+-            if reply:
+-                editwin.io.save(None)
+-            else:
+-                return 0
+-        return 1
++ def confirm_buffer_is_saved(self, editwin):
++ if not editwin.get_saved():
++ name = (editwin.short_title()or
++ editwin.long_title()or
++ "Untitled")
++ reply = tkMessageBox.askokcancel("Bicycle Repair Man",
++ "The buffer for %s is not saved.\n\n"%name+
++ "Save it and continue?",
++ master = self.editwin.text)
++ self.editwin.text.focus_set()
++ if reply:
++ editwin.io.save(None)
++ else:
++ return 0
++ return 1
+
+ def errorbox(self, title, message):
+ tkMessageBox.showerror(title, message, master = self.editwin.text)
+
diff --git a/dev-python/bicyclerepair/files/bicyclerepair-0.9-invalid-syntax.patch b/dev-python/bicyclerepair/files/bicyclerepair-0.9-invalid-syntax.patch
new file mode 100644
index 000000000000..c32fdb621217
--- /dev/null
+++ b/dev-python/bicyclerepair/files/bicyclerepair-0.9-invalid-syntax.patch
@@ -0,0 +1,11 @@
+=== modified file 'bike/query/getPackageDependencies.py'
+--- bike/query/getPackageDependencies.py 2008-07-21 19:37:44 +0000
++++ bike/query/getPackageDependencies.py 2008-07-21 19:38:11 +0000
+@@ -2,5 +2,5 @@
+
+ # fileInPackage is the filename of a file in the package hierarchy
+ def getPackageDependencies(fileInPackage):
+-
++ pass
+
+