summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-12-15 00:39:11 +0000
committerIan Delaney <idella4@gentoo.org>2013-12-15 00:39:11 +0000
commite18d1a851a4ece0041243030f61be9e4f5d5a27c (patch)
tree8f84de08ae54dcbdc3f9a22c7c36ec2c1ad1616e /dev-python/beautifulsoup
parentRevision bump add patch by Julian Ospald <hasufell@gentoo.org> to unbreak fin... (diff)
downloadgentoo-2-e18d1a851a4ece0041243030f61be9e4f5d5a27c.tar.gz
gentoo-2-e18d1a851a4ece0041243030f61be9e4f5d5a27c.tar.bz2
gentoo-2-e18d1a851a4ece0041243030f61be9e4f5d5a27c.zip
bump, troublesome test file -Ignored for now
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/beautifulsoup')
-rw-r--r--dev-python/beautifulsoup/ChangeLog7
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.3.2.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/beautifulsoup/ChangeLog b/dev-python/beautifulsoup/ChangeLog
index ff3569405458..860b40dce0d7 100644
--- a/dev-python/beautifulsoup/ChangeLog
+++ b/dev-python/beautifulsoup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/beautifulsoup
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.103 2013/09/05 18:46:14 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.104 2013/12/15 00:39:11 idella4 Exp $
+
+*beautifulsoup-4.3.2 (15 Dec 2013)
+
+ 15 Dec 2013; Ian Delaney <idella4@gentoo.org> +beautifulsoup-4.3.2.ebuild:
+ bump, troublesome test file -Ignored for now
05 Sep 2013; Michał Górny <mgorny@gentoo.org> beautifulsoup-3.1.0.1-r2.ebuild,
beautifulsoup-3.2.1-r1.ebuild, beautifulsoup-4.1.3-r1.ebuild,
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.3.2.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.3.2.ebuild
new file mode 100644
index 000000000000..a28835f3ab2e
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-4.3.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-4.3.2.ebuild,v 1.1 2013/12/15 00:39:11 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN=${PN}4
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Provides pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/
+ http://pypi.python.org/pypi/beautifulsoup4"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+# new html5 awaits keywording of html5lib in Bug 471002
+IUSE="doc test"
+# pending Bug 471002; html5? ( dev-python/html5lib[$(python_gen_usedep 'python{2_6,2_7}' pypy2_0)] )
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/lxml[$(python_gen_usedep 'python{2_6,2_7}' 'python3*')] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_compile_all() {
+ if use doc; then
+ emake -C doc html
+ fi
+}
+
+python_test() {
+ # https://bugs.launchpad.net/beautifulsoup/+bug/1251451
+ nosetests -w "${BUILD_DIR}"/lib -I test_lxml.py \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=doc/build/html/.
+ distutils-r1_python_install_all
+}