summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-05-22 21:56:45 +0000
committerMike Gilbert <floppym@gentoo.org>2013-05-22 21:56:45 +0000
commit53868cbd4cc9e6212e45caec0a12a9aac6834fb4 (patch)
tree1b2bb4bfd871e54d4554dd52aa8504f9c173c2db /dev-python/beautifulsoup
parentRestore stable keywords. (diff)
downloadgentoo-2-53868cbd4cc9e6212e45caec0a12a9aac6834fb4.tar.gz
gentoo-2-53868cbd4cc9e6212e45caec0a12a9aac6834fb4.tar.bz2
gentoo-2-53868cbd4cc9e6212e45caec0a12a9aac6834fb4.zip
Convert to distutils-r1.
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/beautifulsoup')
-rw-r--r--dev-python/beautifulsoup/ChangeLog8
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r2.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/beautifulsoup/ChangeLog b/dev-python/beautifulsoup/ChangeLog
index a91f07406010..55f4a04bf0ed 100644
--- a/dev-python/beautifulsoup/ChangeLog
+++ b/dev-python/beautifulsoup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/beautifulsoup
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.91 2013/05/22 21:49:29 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.92 2013/05/22 21:56:45 floppym Exp $
+
+*beautifulsoup-3.1.0.1-r2 (22 May 2013)
+
+ 22 May 2013; Mike Gilbert <floppym@gentoo.org>
+ +beautifulsoup-3.1.0.1-r2.ebuild:
+ Convert to distutils-r1.
22 May 2013; Mike Gilbert <floppym@gentoo.org>
beautifulsoup-3.1.0.1-r1.ebuild:
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r2.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r2.ebuild
new file mode 100644
index 000000000000..be3242d0c929
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r2.ebuild,v 1.1 2013/05/22 21:56:45 floppym Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{3_1,3_2,3_3} )
+
+inherit distutils-r1 eutils
+
+MY_PN="BeautifulSoup"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping."
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/ http://pypi.python.org/pypi/BeautifulSoup"
+SRC_URI="http://www.crummy.com/software/${MY_PN}/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="python-3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!dev-python/beautifulsoup:0"
+
+S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}/${P}-python-3.patch" )
+
+python_test() {
+ "${PYTHON}" BeautifulSoupTests.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Delete useless files.
+ rm -r "${ED%/}/usr/bin" || die
+}