summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-23 15:15:42 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-23 15:15:42 +0000
commit131070434001c38e5cf8cbc0cf17b43dfe4af6fc (patch)
tree1da4cd065233240c76a6a5fa3d80ecbd3fa9ccfc /dev-python/beautifulsoup
parentmust not use korn shell /bin/sh as CONFIG_SHELL on hpux too, but bash instead (diff)
downloadgentoo-2-131070434001c38e5cf8cbc0cf17b43dfe4af6fc.tar.gz
gentoo-2-131070434001c38e5cf8cbc0cf17b43dfe4af6fc.tar.bz2
gentoo-2-131070434001c38e5cf8cbc0cf17b43dfe4af6fc.zip
Version bump.
(Portage version: 2.2.0_alpha10_p4/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/beautifulsoup')
-rw-r--r--dev-python/beautifulsoup/ChangeLog8
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.2.0.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/beautifulsoup/ChangeLog b/dev-python/beautifulsoup/ChangeLog
index ecc13096c407..04f0bb0720fc 100644
--- a/dev-python/beautifulsoup/ChangeLog
+++ b/dev-python/beautifulsoup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/beautifulsoup
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.45 2010/12/23 15:06:46 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.46 2010/12/23 15:15:42 arfrever Exp $
+
+*beautifulsoup-3.2.0 (23 Dec 2010)
+
+ 23 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +beautifulsoup-3.2.0.ebuild:
+ Version bump.
23 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
beautifulsoup-3.0.8.1.ebuild, beautifulsoup-3.1.0.1-r1.ebuild:
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.2.0.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.2.0.ebuild
new file mode 100644
index 000000000000..06894da48ee0
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-3.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.2.0.ebuild,v 1.1 2010/12/23 15:15:42 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="BeautifulSoup"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping."
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/ http://pypi.python.org/pypi/BeautifulSoup"
+SRC_URI="http://www.crummy.com/software/${MY_PN}/download/3.x/${MY_P}.tar.gz"
+
+LICENSE="PSF-2.3"
+SLOT="python-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!dev-python/beautifulsoup:0"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="BeautifulSoup.py BeautifulSoupTests.py"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" BeautifulSoupTests.py
+ }
+ python_execute_function testing
+}