summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-07-29 22:27:34 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-07-29 22:27:34 +0000
commit45c42fee013ff7ff8baa51b9cbf2486e17282143 (patch)
treeebc422d478ac01acac6690dfd040af68e2e162fe /dev-python/astng
parentAdd ~x86-linux keyword. (diff)
downloadgentoo-2-45c42fee013ff7ff8baa51b9cbf2486e17282143.tar.gz
gentoo-2-45c42fee013ff7ff8baa51b9cbf2486e17282143.tar.bz2
gentoo-2-45c42fee013ff7ff8baa51b9cbf2486e17282143.zip
Version bump
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/astng')
-rw-r--r--dev-python/astng/ChangeLog8
-rw-r--r--dev-python/astng/astng-0.22.0.ebuild75
-rw-r--r--dev-python/astng/metadata.xml16
3 files changed, 97 insertions, 2 deletions
diff --git a/dev-python/astng/ChangeLog b/dev-python/astng/ChangeLog
index 9f5520cecc03..919030c5452c 100644
--- a/dev-python/astng/ChangeLog
+++ b/dev-python/astng/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/astng
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.51 2011/04/10 20:53:05 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/ChangeLog,v 1.52 2011/07/29 22:27:34 bicatali Exp $
+
+*astng-0.22.0 (29 Jul 2011)
+
+ 29 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org> +astng-0.22.0.ebuild,
+ metadata.xml:
+ Version bump
10 Apr 2011; Markus Meier <maekke@gentoo.org> astng-0.21.1.ebuild:
x86 stable, bug #355273
diff --git a/dev-python/astng/astng-0.22.0.ebuild b/dev-python/astng/astng-0.22.0.ebuild
new file mode 100644
index 000000000000..9d7ceed1250f
--- /dev/null
+++ b/dev-python/astng/astng-0.22.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.22.0.ebuild,v 1.1 2011/07/29 22:27:34 bicatali Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Abstract Syntax Tree New Generation for logilab packages"
+HOMEPAGE="http://www.logilab.org/projects/astng/ http://pypi.python.org/pypi/logilab-astng"
+SRC_URI="ftp://ftp.logilab.org/pub/astng/logilab-${P}.tar.gz mirror://pypi/l/logilab-astng/logilab-${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="test"
+
+# Version specified in __pkginfo__.py.
+RDEPEND=">=dev-python/logilab-common-0.53.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ test? ( >=dev-python/egenix-mx-base-3.0.0 )"
+
+S="${WORKDIR}/logilab-${P}"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+PYTHON_MODNAME="logilab/astng"
+
+src_prepare() {
+ distutils_src_prepare
+
+ conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+ find -name "*.py" ! -name "setup.py" -print | xargs 2to3-${PYTHON_ABI} -nw --no-diffs
+ }
+ python_execute_function -s conversion
+}
+
+src_test() {
+ testing() {
+ local tpath="${T}/test-${PYTHON_ABI}"
+ local spath="${tpath}$(python_get_sitedir)"
+
+ mkdir -p "${spath}/logilab" || return 1
+ cp -r "$(python_get_sitedir)/logilab/common" "${spath}/logilab" || return 1
+
+ "$(PYTHON)" setup.py install --root="${tpath}" || die "Installation for tests failed with $(python_get_implementation) $(python_get_version)"
+
+ # pytest uses tests placed relatively to the current directory.
+ pushd "${spath}/logilab/astng" > /dev/null || return 1
+ if [[ "${PYTHON_ABI}" == 3.* ]]; then
+ # Support for Python 3 is experimental. Some tests are known to fail.
+ PYTHONPATH="${spath}" pytest -v
+ else
+ PYTHONPATH="${spath}" pytest -v || return 1
+ fi
+ popd > /dev/null || return 1
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ distutils_src_install
+
+ deletion_of_unneeded_files() {
+ # Avoid collision with dev-python/logilab-common.
+ rm -f "${ED}$(python_get_sitedir)/logilab/__init__.py" || return 1
+
+ # Don't install tests.
+ rm -fr "${ED}$(python_get_sitedir)/logilab/astng/test" || return 1
+ }
+ python_execute_function -q deletion_of_unneeded_files
+}
diff --git a/dev-python/astng/metadata.xml b/dev-python/astng/metadata.xml
index 301d2207cc29..1b23eefdddfd 100644
--- a/dev-python/astng/metadata.xml
+++ b/dev-python/astng/metadata.xml
@@ -1,5 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
+<herd>python</herd>
+<longdescription lang='en'>
+ The aim of this module is to provide a common base representation of
+ python source code for projects such as pychecker, pyreverse,
+ pylint... Well, actually the development of this library is
+ essentially governed by pylint's needs.
+
+ It provides a compatible representation which comes from the _ast
+ module. It rebuilds the tree generated by the builtin _ast module by
+ recursively walking down the AST and building an extended ast (let's
+ call it astng ;). The new node classes have additional methods and
+ attributes for different usages. They include some support for static
+ inference and local name scopes. Furthermore, astng builds partial
+ trees by inspecting living objects.
+</longdescription>
</pkgmetadata>