summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-09 22:20:03 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-09 22:20:03 +0000
commitd0f0d637f96e2ad788a590aad6bd1caa0bbcb750 (patch)
tree66c3d785e1dba5fd12fadc25c1199cb136cd1c7f /dev-python/arrayterator
parentDelete older ebuild. (diff)
downloadgentoo-2-d0f0d637f96e2ad788a590aad6bd1caa0bbcb750.tar.gz
gentoo-2-d0f0d637f96e2ad788a590aad6bd1caa0bbcb750.tar.bz2
gentoo-2-d0f0d637f96e2ad788a590aad6bd1caa0bbcb750.zip
Set PYTHON_DEPEND.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/arrayterator')
-rw-r--r--dev-python/arrayterator/ChangeLog8
-rw-r--r--dev-python/arrayterator/arrayterator-1.0.1.ebuild17
2 files changed, 14 insertions, 11 deletions
diff --git a/dev-python/arrayterator/ChangeLog b/dev-python/arrayterator/ChangeLog
index 7e3cf86a05d9..da0456aaa268 100644
--- a/dev-python/arrayterator/ChangeLog
+++ b/dev-python/arrayterator/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/arrayterator
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/arrayterator/ChangeLog,v 1.3 2009/09/08 17:12:56 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/arrayterator/ChangeLog,v 1.4 2010/07/09 22:20:03 arfrever Exp $
+
+ 09 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ arrayterator-1.0.1.ebuild:
+ Set PYTHON_DEPEND.
08 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
arrayterator-1.0.1.ebuild:
diff --git a/dev-python/arrayterator/arrayterator-1.0.1.ebuild b/dev-python/arrayterator/arrayterator-1.0.1.ebuild
index cfa729819f8d..ec99c10cea14 100644
--- a/dev-python/arrayterator/arrayterator-1.0.1.ebuild
+++ b/dev-python/arrayterator/arrayterator-1.0.1.ebuild
@@ -1,15 +1,17 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/arrayterator/arrayterator-1.0.1.ebuild,v 1.2 2009/09/08 17:12:56 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/arrayterator/arrayterator-1.0.1.ebuild,v 1.3 2010/07/09 22:20:03 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
DESCRIPTION="This class creates a buffered iterator for reading big arrays in small contiguous blocks."
HOMEPAGE="http://pypi.python.org/pypi/arrayterator"
-SRC_URI="http://cheeseshop.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -18,8 +20,9 @@ IUSE=""
RDEPEND=">=dev-python/numpy-1.0_rc1"
DEPEND="${RDEPEND}
- >=dev-python/setuptools-0.6_rc3"
-RESTRICT_PYTHON_ABIS="3.*"
+ dev-python/setuptools"
+
+PYTHON_MODNAME="arrayterator.py"
src_test() {
cd tests
@@ -29,7 +32,3 @@ src_test() {
}
python_execute_function testing
}
-
-pkg_postinst() {
- python_mod_optimize arrayterator.py
-}