summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-11 01:21:05 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-11 01:21:05 +0000
commitdc4a635c92028925f445c88a4785a18cf7fb6ae8 (patch)
tree2e53414320e67f7d88c90e3b1302e2da5280eace /dev-python/apsw
parentAdded bindist use flag and fixed dep on media-libs/taglib accordingly. (diff)
downloadgentoo-2-dc4a635c92028925f445c88a4785a18cf7fb6ae8.tar.gz
gentoo-2-dc4a635c92028925f445c88a4785a18cf7fb6ae8.tar.bz2
gentoo-2-dc4a635c92028925f445c88a4785a18cf7fb6ae8.zip
Version bump.
(Portage version: 15027-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/ChangeLog8
-rw-r--r--dev-python/apsw/apsw-3.6.21.1.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/apsw/ChangeLog b/dev-python/apsw/ChangeLog
index a18a5a0d59bc..feeb030623dc 100644
--- a/dev-python/apsw/ChangeLog
+++ b/dev-python/apsw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/apsw
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/ChangeLog,v 1.22 2009/12/11 01:10:54 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/ChangeLog,v 1.23 2009/12/11 01:21:05 arfrever Exp $
+
+*apsw-3.6.21.1 (11 Dec 2009)
+
+ 11 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +apsw-3.6.21.1.ebuild:
+ Version bump.
11 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
apsw-3.6.20.1.ebuild, +files/apsw-3.6.20.1-fix_tests.patch:
diff --git a/dev-python/apsw/apsw-3.6.21.1.ebuild b/dev-python/apsw/apsw-3.6.21.1.ebuild
new file mode 100644
index 000000000000..f659e611ea65
--- /dev/null
+++ b/dev-python/apsw/apsw-3.6.21.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.6.21.1.ebuild,v 1.1 2009/12/11 01:21:05 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils versionator
+
+MY_PV="$(replace_version_separator 3 -r)"
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="http://code.google.com/p/apsw/"
+SRC_URI="http://apsw.googlecode.com/files/${PN}-${MY_PV}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-db/sqlite-3.6.6.2"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch"
+}
+
+src_compile() {
+ distutils_src_compile --omit=LOAD_EXTENSION
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" tests.py -v
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ dodoc doc/_sources/*
+ dohtml -r doc/*
+}