summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-05-16 01:03:03 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-05-16 01:03:03 +0000
commit9a8e7f9b4c4b3a6ebb0b810d15cef437cf8002d2 (patch)
tree638fe8a6d1e19748f09e0c3465bc89dc9afbb5d0 /dev-python/amqplib/amqplib-0.6.1-r1.ebuild
parentRemove CC-BY-SA-3.0 from LICENSE. (diff)
downloadgentoo-2-9a8e7f9b4c4b3a6ebb0b810d15cef437cf8002d2.tar.gz
gentoo-2-9a8e7f9b4c4b3a6ebb0b810d15cef437cf8002d2.tar.bz2
gentoo-2-9a8e7f9b4c4b3a6ebb0b810d15cef437cf8002d2.zip
updating amqplib-0.6.1 to r1 for proper quantum support
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/amqplib/amqplib-0.6.1-r1.ebuild')
-rw-r--r--dev-python/amqplib/amqplib-0.6.1-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/amqplib/amqplib-0.6.1-r1.ebuild b/dev-python/amqplib/amqplib-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..5a64e877153d
--- /dev/null
+++ b/dev-python/amqplib/amqplib-0.6.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/amqplib/amqplib-0.6.1-r1.ebuild,v 1.1 2013/05/16 01:03:03 prometheanfire Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python client for the Advanced Message Queuing Procotol (AMQP)"
+HOMEPAGE="http://code.google.com/p/py-amqplib/"
+SRC_URI="http://py-amqplib.googlecode.com/files/${P}.tgz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples extras test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_prepare_all() {
+ if use test; then
+ epatch "${FILESDIR}/${P}_disable_socket_tests.patch"
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" python \
+ "tests/client_0_8/run_all.py"
+ }
+ python_execute_function testing
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc docs/*
+ if use examples; then
+ docinto examples
+ dodoc demo/* || die "dodoc failed"
+ fi
+ if use extras; then
+ insinto /usr/share/${PF}
+ doins -r extras || die "doins failed"
+ fi
+}