summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-16 15:16:08 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-16 15:16:08 +0000
commitc887e57e966dcf809f3ac965df24d5302159a9b7 (patch)
tree33ef946025202a3b8feb33a6e5b0f29934e43826 /dev-python/PyQt
parentDrop qt3support use flag, Version bump (diff)
downloadgentoo-2-c887e57e966dcf809f3ac965df24d5302159a9b7.tar.gz
gentoo-2-c887e57e966dcf809f3ac965df24d5302159a9b7.tar.bz2
gentoo-2-c887e57e966dcf809f3ac965df24d5302159a9b7.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/ChangeLog7
-rw-r--r--dev-python/PyQt/PyQt-3.18.1.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index 71a5550a0340..f153f54d0bd3 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyQt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.118 2009/06/13 21:38:22 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.119 2009/06/16 15:16:08 hwoarang Exp $
+
+*PyQt-3.18.1 (16 Jun 2009)
+
+ 16 Jun 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt-3.18.1.ebuild:
+ Version bump. Bug-fix release
13 Jun 2009; Markos Chandras <hwoarang@gentoo.org> PyQt-3.17.6.ebuild:
Fix sip dependencies
diff --git a/dev-python/PyQt/PyQt-3.18.1.ebuild b/dev-python/PyQt/PyQt-3.18.1.ebuild
new file mode 100644
index 000000000000..9331670ae730
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.18.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.18.1.ebuild,v 1.1 2009/06/16 15:16:08 hwoarang Exp $
+
+EAPI="2"
+inherit distutils
+
+MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A set of Python bindings for Qt3"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/PyQt3/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples"
+
+RDEPEND="x11-libs/qt:3
+ >=dev-python/sip-4.8
+ >=x11-libs/qscintilla-2.4[python]"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_prepare() {
+ sed -i -e "s: check_license():# check_license():" "${S}"/configure.py
+}
+
+src_configure() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d $(python_get_sitedir) \
+ -b /usr/bin \
+ -v /usr/share/sip \
+ -n /usr/include \
+ -o /usr/$(get_libdir) \
+ -w -y qt-mt
+ -u"
+ use debug && myconf="${myconf} -u"
+
+ "${python}" configure.py ${myconf} || die 'configure failed'
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ python_need_rebuild
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README THANKS
+ use doc && dohtml doc/PyQt.html
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples3/* "${D}"/usr/share/doc/${PF}/examples
+ fi
+}