summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-06-26 14:49:23 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-06-26 14:49:23 +0000
commite8afaaae7571492d89eba9c190a18049ae8771d8 (patch)
treed95d81196a08db6ed8feae8855ca2e6b1d6f7e37 /dev-python/PyQt4
parentStable on sparc (diff)
downloadgentoo-2-e8afaaae7571492d89eba9c190a18049ae8771d8.tar.gz
gentoo-2-e8afaaae7571492d89eba9c190a18049ae8771d8.tar.bz2
gentoo-2-e8afaaae7571492d89eba9c190a18049ae8771d8.zip
adding the release version
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'dev-python/PyQt4')
-rw-r--r--dev-python/PyQt4/ChangeLog7
-rw-r--r--dev-python/PyQt4/PyQt4-4.0.ebuild59
-rw-r--r--dev-python/PyQt4/files/digest-PyQt4-4.03
3 files changed, 68 insertions, 1 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 5e770170400f..a165c2998f6c 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.1 2006/05/05 17:07:56 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.2 2006/06/26 14:49:23 caleb Exp $
+
+*PyQt4-4.0 (26 Jun 2006)
+
+ 26 Jun 2006; Caleb Tennis <caleb@gentoo.org> +PyQt4-4.0.ebuild:
+ adding the release version
*PyQt4-4.0_beta1 (05 May 2006)
diff --git a/dev-python/PyQt4/PyQt4-4.0.ebuild b/dev-python/PyQt4/PyQt4-4.0.ebuild
new file mode 100644
index 000000000000..e10f17f0132d
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.0.ebuild,v 1.1 2006/06/26 14:49:23 caleb Exp $
+
+inherit distutils
+
+MY_P="PyQt-x11-gpl-${PV/_beta/beta}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+#SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+SRC_URI="http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/${MY_P}.tar.gz"
+#SRC_URI="http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt3/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="debug doc examples"
+
+RDEPEND="=x11-libs/qt-4*
+ >=dev-python/sip-4.4.5"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:^[ \t]*check_license():# check_license():" ${S}/configure.py
+ sed -i -e "s:join(qt_dir, \"mkspecs\":join(\"/usr/share/qt4\", \"mkspecs\":g" ${S}/configure.py
+ sed -i -e "s:\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include\":\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include/qt4\":g" ${S}/configure.py
+ sed -i -e "s:\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib\":\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib/qt4\":g" ${S}/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/PyQt4 \
+ -b ${ROOT}/usr/bin \
+ -v ${ROOT}/usr/share/sip" #\
+# -n ${ROOT}/usr/include \
+# -o ${ROOT}/usr/$(get_libdir) \
+# -w -y qt-mt"
+ use debug && myconf="${myconf} -u"
+
+ python configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
+ use doc && dohtml doc/PyQt.html
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples3/* ${D}/usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/PyQt4/files/digest-PyQt4-4.0 b/dev-python/PyQt4/files/digest-PyQt4-4.0
new file mode 100644
index 000000000000..baa0b66b8ea0
--- /dev/null
+++ b/dev-python/PyQt4/files/digest-PyQt4-4.0
@@ -0,0 +1,3 @@
+MD5 54f6efed36f3ddd59c5d26b5af88576f PyQt-x11-gpl-4.0.tar.gz 4667872
+RMD160 86e43b2cac683a1ae6f3163fee7372b4caf15df4 PyQt-x11-gpl-4.0.tar.gz 4667872
+SHA256 1fc4b7a5a9fc47b4b093bc0c155b909547b5e8fdcca2dd824f572df44d6b5ec9 PyQt-x11-gpl-4.0.tar.gz 4667872