summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-05-24 22:10:20 +0000
committerBen de Groot <yngwin@gentoo.org>2008-05-24 22:10:20 +0000
commit3e62b60c4218a77ca52e0d67ede524d6b0a47797 (patch)
tree007d22148714165dd13112481d49e7c0218672ae /dev-python/PyQt4
parentAdded qt3support useflag for dev-python/PyQt4 to use.local.desc (diff)
downloadgentoo-2-3e62b60c4218a77ca52e0d67ede524d6b0a47797.tar.gz
gentoo-2-3e62b60c4218a77ca52e0d67ede524d6b0a47797.tar.bz2
gentoo-2-3e62b60c4218a77ca52e0d67ede524d6b0a47797.zip
Version bump. Added split qt4 deps from bug 222709.
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-python/PyQt4')
-rw-r--r--dev-python/PyQt4/ChangeLog7
-rw-r--r--dev-python/PyQt4/PyQt4-4.4.2.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 8e5bd602b79b..009ee6dbb8b7 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.30 2008/05/14 20:16:36 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.31 2008/05/24 22:10:20 yngwin Exp $
+
+*PyQt4-4.4.2 (24 May 2008)
+
+ 24 May 2008; Ben de Groot <yngwin@gentoo.org> +PyQt4-4.4.2.ebuild:
+ Version bump. Updated homepage URL. Added split qt deps from bug 222709.
*PyQt4-4.4 (14 May 2008)
diff --git a/dev-python/PyQt4/PyQt4-4.4.2.ebuild b/dev-python/PyQt4/PyQt4-4.4.2.ebuild
new file mode 100644
index 000000000000..400bd975335a
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.4.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.4.2.ebuild,v 1.1 2008/05/24 22:10:20 yngwin Exp $
+
+EAPI=1
+
+inherit distutils qt4
+
+MY_P=PyQt-x11-gpl-${PV}
+
+DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/PyQt4/${MY_P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus debug doc examples opengl qt3support svg X"
+
+RDEPEND=">=dev-python/sip-4.7.6
+ || ( ( x11-libs/qt-core:4
+ dbus? ( x11-libs/qt-dbus:4 )
+ opengl? ( x11-libs/qt-opengl:4 )
+ svg? ( x11-libs/qt-svg:4 )
+ qt3support? ( x11-libs/qt-qt3support:4 )
+ X? ( x11-libs/qt-gui:4 ) )
+ =x11-libs/qt-4* )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S=${WORKDIR}/${MY_P}
+
+QT4_BUILT_WITH_USE_CHECK="zlib"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:^[ \t]*check_license():# check_license():" "${S}"/configure.py
+ sed -i -e "s:join(qt_dir, \"mkspecs\":join(\"/usr/share/qt4\", \"mkspecs\":g" "${S}"/configure.py
+ sed -i -e "s:\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include\":\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include/qt4\":g" "${S}"/configure.py
+ sed -i -e "s:\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib\":\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib/qt4\":g" "${S}"/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin -v /usr/share/sip"
+ use debug && myconf="${myconf} -u"
+
+ "${python}" configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README THANKS
+ use doc && dohtml -r doc/html/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}