summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-23 17:51:25 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-23 17:51:25 +0000
commitfedddd9af02f44ff9a54c6791fa3609ed581ca3d (patch)
tree1f02ddee3e829c94cc039abf95ab791c0b3991e4 /dev-python/4suite
parentRemove virtual/libc (diff)
downloadgentoo-2-fedddd9af02f44ff9a54c6791fa3609ed581ca3d.tar.gz
gentoo-2-fedddd9af02f44ff9a54c6791fa3609ed581ca3d.tar.bz2
gentoo-2-fedddd9af02f44ff9a54c6791fa3609ed581ca3d.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14395-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/4suite')
-rw-r--r--dev-python/4suite/4suite-1.0.2-r1.ebuild50
-rw-r--r--dev-python/4suite/ChangeLog6
2 files changed, 31 insertions, 25 deletions
diff --git a/dev-python/4suite/4suite-1.0.2-r1.ebuild b/dev-python/4suite/4suite-1.0.2-r1.ebuild
index ff13bdb9e195..9845d880d2e3 100644
--- a/dev-python/4suite/4suite-1.0.2-r1.ebuild
+++ b/dev-python/4suite/4suite-1.0.2-r1.ebuild
@@ -1,10 +1,13 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/4suite-1.0.2-r1.ebuild,v 1.7 2008/06/22 15:54:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/4suite-1.0.2-r1.ebuild,v 1.8 2009/09/23 17:51:25 arfrever Exp $
-inherit distutils eutils multilib
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
-MY_P=4Suite-XML-${PV}
+inherit distutils eutils
+
+MY_P="4Suite-XML-${PV}"
DESCRIPTION="Python tools for XML processing and object-databases."
SRC_URI="mirror://sourceforge/foursuite/${MY_P}.tar.bz2"
@@ -16,37 +19,36 @@ IUSE="doc"
DEPEND=">=dev-python/pyxml-0.8.4"
RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
PYTHON_MODNAME="Ft"
DOCS="docs/*.txt"
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}-amd64_python2.5.patch"
epatch "${FILESDIR}/${P}-config.patch"
-}
-src_compile() {
- if ! use doc ; then
- sed -i -e "/'build_docs'/d" \
- Ft/Lib/DistExt/Build.py || die "sed failed"
+ if ! use doc; then
+ sed -e "/'build_docs'/d" -i Ft/Lib/DistExt/Build.py || die "sed failed"
fi
- distutils_python_version
- "${python}" setup.py config \
- --prefix=/usr \
- --docdir=/usr/share/doc/${PF} \
- --datadir=/usr/share/${PN} \
- --libdir=/usr/$(get_libdir)/python${PYVER}/site-packages || die "setup.py config failed"
-
- distutils_src_compile
+ distutils_src_prepare
+}
+
+src_configure() {
+ configuration() {
+ "$(PYTHON)" setup.py config \
+ --prefix=/usr \
+ --docdir=/usr/share/doc/${PF} \
+ --datadir=/usr/share/${PN} \
+ --libdir="$(python_get_sitedir)" || die "setup.py config failed with Python ${PYTHON_ABI}"
+ }
+ python_execute_function configuration
}
src_install() {
- rm -r test profile
- distutils_src_install \
- $(use_with doc docs) \
- --install-lib="/usr/$(get_libdir)/python${PYVER}/site-packages"
+ rm -fr profile test
+ distutils_src_install $(use_with doc docs)
+ rm -fr "${D}"usr/$(get_libdir)/python*/site-packages/{profiles,tests}
}
diff --git a/dev-python/4suite/ChangeLog b/dev-python/4suite/ChangeLog
index 1648c1106bdb..0fbe805811a5 100644
--- a/dev-python/4suite/ChangeLog
+++ b/dev-python/4suite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/4suite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/ChangeLog,v 1.42 2009/09/06 23:07:43 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/ChangeLog,v 1.43 2009/09/23 17:51:25 arfrever Exp $
+
+ 23 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ 4suite-1.0.2-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
06 Sep 2009; Christian Ruppert <idl0r@gentoo.org>
-files/1.0_b3-add_root_opt.diff: