summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-01-20 03:56:58 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-01-20 03:56:58 +0000
commitf666604a070a71dfe59b3adfcfe7d809f7da5f49 (patch)
treed540ba7cf364e434ac1d619b2729005fff57f6cc /dev-python/4suite
parentChanges for bug 74929. (diff)
downloadgentoo-2-f666604a070a71dfe59b3adfcfe7d809f7da5f49.tar.gz
gentoo-2-f666604a070a71dfe59b3adfcfe7d809f7da5f49.tar.bz2
gentoo-2-f666604a070a71dfe59b3adfcfe7d809f7da5f49.zip
Version bump. bug# 78517 Thanks for patches Jacob Smullyan <smulloni@smullyan.org> and kutsya@gentoo.org
(Portage version: 2.0.51-r14)
Diffstat (limited to 'dev-python/4suite')
-rw-r--r--dev-python/4suite/4suite-1.0_alpha3.ebuild4
-rw-r--r--dev-python/4suite/4suite-1.0_alpha4.ebuild39
-rw-r--r--dev-python/4suite/ChangeLog11
-rw-r--r--dev-python/4suite/Manifest4
-rw-r--r--dev-python/4suite/files/digest-4suite-1.0_alpha41
5 files changed, 54 insertions, 5 deletions
diff --git a/dev-python/4suite/4suite-1.0_alpha3.ebuild b/dev-python/4suite/4suite-1.0_alpha3.ebuild
index 28f4397a85dc..e0c5c5d943db 100644
--- a/dev-python/4suite/4suite-1.0_alpha3.ebuild
+++ b/dev-python/4suite/4suite-1.0_alpha3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/4suite-1.0_alpha3.ebuild,v 1.8 2004/07/04 09:55:02 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/4suite-1.0_alpha3.ebuild,v 1.9 2005/01/20 03:56:58 pythonhead Exp $
inherit distutils
diff --git a/dev-python/4suite/4suite-1.0_alpha4.ebuild b/dev-python/4suite/4suite-1.0_alpha4.ebuild
new file mode 100644
index 000000000000..5d6f160dc35f
--- /dev/null
+++ b/dev-python/4suite/4suite-1.0_alpha4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/4suite-1.0_alpha4.ebuild,v 1.1 2005/01/20 03:56:58 pythonhead Exp $
+
+inherit distutils eutils
+
+MY_P=${P/_alpha/a}
+MY_P=${MY_P/4s/4S}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Python tools for XML processing and object-databases."
+SRC_URI="mirror://sourceforge/foursuite/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.4suite.org/"
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/pyxml-0.8.3"
+
+IUSE="doc"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+LICENSE="Apache-1.1"
+
+PYTHON_MODNAME="Ft"
+DOCS="docs/*.txt"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/4S-1.0_a4.addrootopt-gentoo.diff
+ python setup.py config --prefix=/usr --docdir=/usr/share/doc/${P}
+}
+
+src_install() {
+ if use doc; then
+ distutils_src_install --with-docs
+ else
+ distutils_src_install
+ fi
+}
diff --git a/dev-python/4suite/ChangeLog b/dev-python/4suite/ChangeLog
index 0bfa51e49b22..0ba06f8e1197 100644
--- a/dev-python/4suite/ChangeLog
+++ b/dev-python/4suite/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/4suite
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/ChangeLog,v 1.11 2004/12/30 21:05:11 ciaranm Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/ChangeLog,v 1.12 2005/01/20 03:56:58 pythonhead Exp $
+
+*4suite-1.0_alpha4 (19 Jan 2005)
+
+ 19 Jan 2005; Rob Cakebread <pythonhead@gentoo.org>
+ +4suite-1.0_alpha4.ebuild:
+ Version bump. bug# 78517 Thanks for patches Jacob Smullyan
+ <smulloni@smullyan.org> and kutsya@gentoo.org
30 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/dev-python/4suite/Manifest b/dev-python/4suite/Manifest
index 10b83d0f2416..23f35f870656 100644
--- a/dev-python/4suite/Manifest
+++ b/dev-python/4suite/Manifest
@@ -1,4 +1,6 @@
-MD5 a7c35d0ef477d31d5502256859c7ac5d ChangeLog 2592
+MD5 86a301aff4087e972a26bab0990e2e1c 4suite-1.0_alpha4.ebuild 808
MD5 167fd761ef2da6aab1dca11d47d33002 4suite-1.0_alpha3.ebuild 606
+MD5 a7c35d0ef477d31d5502256859c7ac5d ChangeLog 2592
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
+MD5 880f1fc88e78283a8665b8b0e45b95de files/digest-4suite-1.0_alpha4 66
MD5 0724d222f5540595a368fb7acd27c1f9 files/digest-4suite-1.0_alpha3 65
diff --git a/dev-python/4suite/files/digest-4suite-1.0_alpha4 b/dev-python/4suite/files/digest-4suite-1.0_alpha4
new file mode 100644
index 000000000000..3885f0e0de73
--- /dev/null
+++ b/dev-python/4suite/files/digest-4suite-1.0_alpha4
@@ -0,0 +1 @@
+MD5 7a5de1ac3d336b7198b741be83d0722e 4Suite-1.0a4.tar.bz2 1764971