summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-04-18 11:11:46 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-04-18 11:11:46 +0000
commit0537f0885f78afcce87d6420c726b96202a84b04 (patch)
tree9f6697c33c645af171566fc2045ec4f80d91bb97 /dev-python/4suite
parentAdded gxine 0.4.3. Needs sparc and ppc64 test spidermonkey for their keywords. (diff)
downloadgentoo-2-0537f0885f78afcce87d6420c726b96202a84b04.tar.gz
gentoo-2-0537f0885f78afcce87d6420c726b96202a84b04.tar.bz2
gentoo-2-0537f0885f78afcce87d6420c726b96202a84b04.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-python/4suite')
-rw-r--r--dev-python/4suite/4suite-1.0_beta1.ebuild39
-rw-r--r--dev-python/4suite/ChangeLog7
-rw-r--r--dev-python/4suite/Manifest16
-rw-r--r--dev-python/4suite/files/digest-4suite-1.0_beta11
4 files changed, 50 insertions, 13 deletions
diff --git a/dev-python/4suite/4suite-1.0_beta1.ebuild b/dev-python/4suite/4suite-1.0_beta1.ebuild
new file mode 100644
index 000000000000..0f3cc4c587a7
--- /dev/null
+++ b/dev-python/4suite/4suite-1.0_beta1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/4suite-1.0_beta1.ebuild,v 1.1 2005/04/18 11:11:46 liquidx Exp $
+
+inherit distutils eutils
+
+MY_P=${P/_beta/b}
+MY_P=${MY_P/4s/4S}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Python tools for XML processing and object-databases."
+SRC_URI="mirror://sourceforge/foursuite/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.4suite.org/"
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/pyxml-0.8.3"
+
+IUSE="doc"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc ~amd64"
+LICENSE="Apache-1.1"
+
+PYTHON_MODNAME="Ft"
+DOCS="docs/*.txt"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/4S-1.0_a4.addrootopt-gentoo.diff
+ python setup.py config --prefix=/usr --docdir=/usr/share/doc/${P}
+}
+
+src_install() {
+ if use doc; then
+ distutils_src_install --with-docs
+ else
+ distutils_src_install
+ fi
+}
diff --git a/dev-python/4suite/ChangeLog b/dev-python/4suite/ChangeLog
index b38d6e4408c6..0c9f8392ee4c 100644
--- a/dev-python/4suite/ChangeLog
+++ b/dev-python/4suite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/4suite
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/ChangeLog,v 1.13 2005/03/20 18:05:25 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/4suite/ChangeLog,v 1.14 2005/04/18 11:11:46 liquidx Exp $
+
+*4suite-1.0_beta1 (18 Apr 2005)
+
+ 18 Apr 2005; Alastair Tse <liquidx@gentoo.org> +4suite-1.0_beta1.ebuild:
+ version bump
20 Mar 2005; Heinrich Wendel <lanius@gentoo.org> 4suite-1.0_alpha4.ebuild:
add amd64 keyword
diff --git a/dev-python/4suite/Manifest b/dev-python/4suite/Manifest
index ceec32d25a9a..866f2c9eb16f 100644
--- a/dev-python/4suite/Manifest
+++ b/dev-python/4suite/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 72aa6941a6afc35089f525c1f9658f83 4suite-1.0_alpha3.ebuild 610
-MD5 cdc88b46e1863c72d516acaf912a5589 4suite-1.0_alpha4.ebuild 919
MD5 24eee0dd9820b4d379457037e9f2d132 ChangeLog 2915
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
-MD5 4814d18b806331ba9c6ef9340ed67f74 files/4S-1.0_a4.addrootopt-gentoo.diff 464
+MD5 cdc88b46e1863c72d516acaf912a5589 4suite-1.0_alpha4.ebuild 919
+MD5 af79e8867fca729663c607aeb6906e7f 4suite-1.0_beta1.ebuild 918
MD5 0724d222f5540595a368fb7acd27c1f9 files/digest-4suite-1.0_alpha3 65
+MD5 4814d18b806331ba9c6ef9340ed67f74 files/4S-1.0_a4.addrootopt-gentoo.diff 464
MD5 880f1fc88e78283a8665b8b0e45b95de files/digest-4suite-1.0_alpha4 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFCPbuZevY57Fted3ERAqaGAKCMkTxxALIvZB8SZ4Uw10ECqvw0ywCfTP51
-h1CmWETuJU/W0/ZrfGPaASM=
-=6pL+
------END PGP SIGNATURE-----
+MD5 4accf062639961ade3688282243879b4 files/digest-4suite-1.0_beta1 66
diff --git a/dev-python/4suite/files/digest-4suite-1.0_beta1 b/dev-python/4suite/files/digest-4suite-1.0_beta1
new file mode 100644
index 000000000000..cf65d592ef69
--- /dev/null
+++ b/dev-python/4suite/files/digest-4suite-1.0_beta1
@@ -0,0 +1 @@
+MD5 d512d79dcbe08584d0b5ba4c9704a820 4Suite-1.0b1.tar.bz2 1524266