summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-07 02:31:32 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-07 02:31:32 +0000
commite4cf68863cbb153e8a06fa0ec19bbcbc47b604ca (patch)
tree9ce884064ac2b5382863e2eccdf989aca92987c1 /dev-php
parentfix license/repoman (diff)
downloadgentoo-2-e4cf68863cbb153e8a06fa0ec19bbcbc47b604ca.tar.gz
gentoo-2-e4cf68863cbb153e8a06fa0ec19bbcbc47b604ca.tar.bz2
gentoo-2-e4cf68863cbb153e8a06fa0ec19bbcbc47b604ca.zip
fix license/repoman
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/jpgraph/jpgraph-1.12.2.ebuild29
-rw-r--r--dev-php/phpgroupware/phpgroupware-0.9.14.005.ebuild12
-rw-r--r--dev-php/phpgroupware/phpgroupware-0.9.14.006.ebuild12
3 files changed, 20 insertions, 33 deletions
diff --git a/dev-php/jpgraph/jpgraph-1.12.2.ebuild b/dev-php/jpgraph/jpgraph-1.12.2.ebuild
index f81601672172..118a14fa370b 100644
--- a/dev-php/jpgraph/jpgraph-1.12.2.ebuild
+++ b/dev-php/jpgraph/jpgraph-1.12.2.ebuild
@@ -1,39 +1,31 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Released under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-php/jpgraph/jpgraph-1.12.2.ebuild,v 1.3 2003/08/04 23:43:56 stuart Exp $
-#
-# Based on the ebuild submitted by ??
+# Released under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/jpgraph/jpgraph-1.12.2.ebuild,v 1.4 2003/08/07 02:31:32 vapier Exp $
-DESCRIPTION="JpGraph is a fully OO graph drawing library for PHP."
+inherit php-lib
+
+DESCRIPTION="fully OO graph drawing library for PHP"
HOMEPAGE="http://www.aditus.nu/jpgraph/"
SRC_URI="http://www.aditus.nu/jpgraph/downloads/${P}.tar.gz"
-# QPL license for non-commercial use, regular commercial license available
LICENSE="QPL-1.0"
-
-IUSE="truetype"
-
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="truetype"
+
DEPEND=""
RDEPEND="virtual/php
- >=media-libs/libgd-1.8"
+ >=media-libs/libgd-1.8"
-S="${WORKDIR}/${P}"
JPGRAPH_CACHE_DIR="/var/cache/jpgraph"
-inherit php-lib
-
-# setup defaults in case we don't have a web server installed
-
HTTPD_USER=root
HTTPD_GROUP=root
has_version "net-www/apache" && USE_APACHE=1 && inherit webapp-apache
[ -n $"{USE_APACHE}" ] && webapp-detect || NO_WEBSERVER=1
-pkg_setup ()
-{
+pkg_setup() {
if [ "${NO_WEBSERVER}" = "1" ]; then
ewarn "No webserver detected - ${JPGRAPH_CACHE_DIR} will be"
ewarn "owned by ${HTTPD_USER} instead"
@@ -42,8 +34,7 @@ pkg_setup ()
fi
}
-src_install ()
-{
+src_install() {
einfo "Patching jpgraph.php"
# patch 1:
diff --git a/dev-php/phpgroupware/phpgroupware-0.9.14.005.ebuild b/dev-php/phpgroupware/phpgroupware-0.9.14.005.ebuild
index 3b8242fc42e2..9b7ec13ebc04 100644
--- a/dev-php/phpgroupware/phpgroupware-0.9.14.005.ebuild
+++ b/dev-php/phpgroupware/phpgroupware-0.9.14.005.ebuild
@@ -1,25 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/phpgroupware-0.9.14.005.ebuild,v 1.1 2003/07/07 17:42:33 mholzer Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/phpgroupware-0.9.14.005.ebuild,v 1.2 2003/08/07 02:27:23 vapier Exp $
S=${WORKDIR}/${PN}
HTTPD_ROOT="/home/httpd/htdocs"
HTTPD_USER="apache"
HTTPD_GROUP="apache"
-DESCRIPTION="The phpGroupWare intranet/groupware tool and application framework."
+DESCRIPTION="intranet/groupware tool and application framework"
+HOMEPAGE="http://www.phpgroupware.org/"
SRC_URI="mirror://sourceforge/phpgroupware/${P}.tar.bz2"
-HOMEPAGE="http://www.phpgroupware.org"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha"
-IUSE=""
DEPEND="virtual/php
dev-db/mysql"
-
pkg_setup() {
if [ -L ${HTTPD_ROOT}/phpgroupware ] ; then
ewarn "You need to unmerge your old phpGroupWare version first."
@@ -34,7 +32,7 @@ src_compile() {
echo "Nothing to compile"
}
-src_install () {
+src_install() {
dodir ${HTTPD_ROOT}/phpgroupware
cd ${WORKDIR}
cp -r . ${D}/${HTTPD_ROOT}
diff --git a/dev-php/phpgroupware/phpgroupware-0.9.14.006.ebuild b/dev-php/phpgroupware/phpgroupware-0.9.14.006.ebuild
index f256c2f9cc2b..72858fb89e47 100644
--- a/dev-php/phpgroupware/phpgroupware-0.9.14.006.ebuild
+++ b/dev-php/phpgroupware/phpgroupware-0.9.14.006.ebuild
@@ -1,25 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/phpgroupware-0.9.14.006.ebuild,v 1.1 2003/07/24 16:33:20 mholzer Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/phpgroupware-0.9.14.006.ebuild,v 1.2 2003/08/07 02:27:23 vapier Exp $
S=${WORKDIR}/${PN}
HTTPD_ROOT="/home/httpd/htdocs"
HTTPD_USER="apache"
HTTPD_GROUP="apache"
-DESCRIPTION="The phpGroupWare intranet/groupware tool and application framework."
+DESCRIPTION="intranet/groupware tool and application framework"
+HOMEPAGE="http://www.phpgroupware.org/"
SRC_URI="mirror://sourceforge/phpgroupware/${P}.tar.bz2"
-HOMEPAGE="http://www.phpgroupware.org"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~sparc ~hppa ~arm"
-IUSE=""
DEPEND="virtual/php
dev-db/mysql"
-
pkg_setup() {
if [ -L ${HTTPD_ROOT}/phpgroupware ] ; then
ewarn "You need to unmerge your old phpGroupWare version first."
@@ -34,7 +32,7 @@ src_compile() {
echo "Nothing to compile"
}
-src_install () {
+src_install() {
dodir ${HTTPD_ROOT}/phpgroupware
cd ${WORKDIR}
cp -r . ${D}/${HTTPD_ROOT}