summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-03-10 21:04:54 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-03-10 21:04:54 +0000
commitdf9b2ba42c6c274d861c02c9ed39664d2e5a3723 (patch)
tree7e67fb83d8149347b24d7cb402d199c340aa8a82 /dev-php
parentAdded the forgotten patch (diff)
downloadgentoo-2-df9b2ba42c6c274d861c02c9ed39664d2e5a3723.tar.gz
gentoo-2-df9b2ba42c6c274d861c02c9ed39664d2e5a3723.tar.bz2
gentoo-2-df9b2ba42c6c274d861c02c9ed39664d2e5a3723.zip
Revbump with cleaner deps
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-http/ChangeLog8
-rw-r--r--dev-php/pecl-http/pecl-http-1.7.3-r1.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-php/pecl-http/ChangeLog b/dev-php/pecl-http/ChangeLog
index 12740887d4b6..b610d093b639 100644
--- a/dev-php/pecl-http/ChangeLog
+++ b/dev-php/pecl-http/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/pecl-http
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-http/ChangeLog,v 1.6 2012/03/08 18:05:34 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-http/ChangeLog,v 1.7 2012/03/10 21:04:54 olemarkus Exp $
+
+*pecl-http-1.7.3-r1 (10 Mar 2012)
+
+ 10 Mar 2012; Ole Markus With <olemarkus@gentoo.org>
+ +pecl-http-1.7.3-r1.ebuild:
+ Revbump with cleaner deps
*pecl-http-1.7.3 (08 Mar 2012)
diff --git a/dev-php/pecl-http/pecl-http-1.7.3-r1.ebuild b/dev-php/pecl-http/pecl-http-1.7.3-r1.ebuild
new file mode 100644
index 000000000000..cf4e08738997
--- /dev/null
+++ b/dev-php/pecl-http/pecl-http-1.7.3-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-http/pecl-http-1.7.3-r1.ebuild,v 1.1 2012/03/10 21:04:54 olemarkus Exp $
+
+EAPI="4"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="docs/examples/tutorial.txt ThanksTo.txt KnownIssues.txt"
+
+USE_PHP="php5-3 php5-4"
+
+inherit php-ext-pecl-r2 php-ext-source-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP."
+LICENSE="BSD-2 MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=net-misc/curl-7.19.4
+ sys-libs/zlib
+ dev-libs/libevent
+ >=dev-lang/php-5[hash,session,iconv]
+ "
+RDEPEND="${DEPEND}"
+
+my_conf="--enable-http \
+ --with-http-curl-requests \
+ --with-http-zlib-compression \
+ --with-http-curl-libevent \
+ --with-http-magic-mime"
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "http.etag.mode" "MD5"
+ php-ext-source-r2_addtoinifiles "http.force_exit" "1"
+ php-ext-source-r2_addtoinifiles "http.log.allowed_methods" ""
+ php-ext-source-r2_addtoinifiles "http.log.cache" ""
+ php-ext-source-r2_addtoinifiles "http.log.composite" ""
+ php-ext-source-r2_addtoinifiles "http.log.not_found" ""
+ php-ext-source-r2_addtoinifiles "http.log.redirect" ""
+ php-ext-source-r2_addtoinifiles "http.only_exceptions" "0"
+ php-ext-source-r2_addtoinifiles "http.persistent.handles.ident" "GLOBAL"
+ php-ext-source-r2_addtoinifiles "http.persistent.handles.limit" "-1"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.connect" "0"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.cookie" "0"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.dns" "1"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.ssl" "0"
+ php-ext-source-r2_addtoinifiles "http.request.methods.allowed" ""
+ php-ext-source-r2_addtoinifiles "http.request.methods.custom" ""
+ php-ext-source-r2_addtoinifiles "http.send.inflate.start_auto" "0"
+ php-ext-source-r2_addtoinifiles "http.send.inflate.start_flags" "0"
+ php-ext-source-r2_addtoinifiles "http.send.deflate.start_auto" "0"
+ php-ext-source-r2_addtoinifiles "http.send.deflate.start_flags" "0"
+ php-ext-source-r2_addtoinifiles "http.send.not_found_404" "1"
+}