summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-04-29 01:33:04 +0000
committerBrian Evans <grknight@gentoo.org>2015-04-29 01:33:04 +0000
commitce368afe888aa4021b4d4f38f8c3e18b159894ee (patch)
tree9dba60f8c7fe62e3834902b0e551c52502d3deb1 /dev-php
parentRevbump to make dependencies more specific and silence repoman (diff)
downloadgentoo-2-ce368afe888aa4021b4d4f38f8c3e18b159894ee.tar.gz
gentoo-2-ce368afe888aa4021b4d4f38f8c3e18b159894ee.tar.bz2
gentoo-2-ce368afe888aa4021b4d4f38f8c3e18b159894ee.zip
Revbump to make dependencies more specific and silence repoman
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xD1F781EFF9F4A3B6)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-oauth/ChangeLog10
-rw-r--r--dev-php/pecl-oauth/pecl-oauth-1.2.3-r2.ebuild (renamed from dev-php/pecl-oauth/pecl-oauth-1.2.3-r1.ebuild)13
2 files changed, 18 insertions, 5 deletions
diff --git a/dev-php/pecl-oauth/ChangeLog b/dev-php/pecl-oauth/ChangeLog
index ae8606ff9359..5334ad78527f 100644
--- a/dev-php/pecl-oauth/ChangeLog
+++ b/dev-php/pecl-oauth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/pecl-oauth
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-oauth/ChangeLog,v 1.6 2014/09/30 22:56:20 grknight Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-oauth/ChangeLog,v 1.7 2015/04/29 01:33:04 grknight Exp $
+
+*pecl-oauth-1.2.3-r2 (29 Apr 2015)
+
+ 29 Apr 2015; Brian Evans <grknight@gentoo.org> +pecl-oauth-1.2.3-r2.ebuild,
+ -pecl-oauth-1.2.3-r1.ebuild:
+ Revbump to make dependencies more specific and silence repoman
*pecl-oauth-1.2.3-r1 (30 Sep 2014)
diff --git a/dev-php/pecl-oauth/pecl-oauth-1.2.3-r1.ebuild b/dev-php/pecl-oauth/pecl-oauth-1.2.3-r2.ebuild
index 6b32818e736c..cf7f27c960d6 100644
--- a/dev-php/pecl-oauth/pecl-oauth-1.2.3-r1.ebuild
+++ b/dev-php/pecl-oauth/pecl-oauth-1.2.3-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-oauth/pecl-oauth-1.2.3-r1.ebuild,v 1.1 2014/09/30 22:56:20 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-oauth/pecl-oauth-1.2.3-r2.ebuild,v 1.1 2015/04/29 01:33:04 grknight Exp $
EAPI="5"
PHP_EXT_NAME="oauth"
@@ -19,5 +19,12 @@ LICENSE="BSD"
SLOT="0"
IUSE=""
-DEPEND="dev-lang/php[hash]"
+for target in ${USE_PHP}; do
+ slot=${target/php}
+ slot=${slot/-/.}
+ PHPUSEDEPEND="${PHPUSEDEPEND}
+ php_targets_${target}? ( dev-lang/php:${slot}[hash] )"
+done
+
+DEPEND="${PHPUSEDEPEND}"
RDEPEND="${DEPEND}"