summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-03-28 17:00:40 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-03-28 17:00:40 +0000
commitbecac2f3d3e07ef4359b78214a9f414f3252acbb (patch)
tree9558a07565744ed4723ccd2c27f70e1de574f136 /dev-php
parentVersion bump. Dropped sparc because it was dropped for sci-physics/root (diff)
downloadgentoo-2-becac2f3d3e07ef4359b78214a9f414f3252acbb.tar.gz
gentoo-2-becac2f3d3e07ef4359b78214a9f414f3252acbb.tar.bz2
gentoo-2-becac2f3d3e07ef4359b78214a9f414f3252acbb.zip
Version bump.
(Portage version: 2.1.9.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug-client/ChangeLog7
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.1.1.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index 85b8847fdd71..74194634b76f 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/xdebug-client
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.27 2011/03/28 16:55:44 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.28 2011/03/28 17:00:40 olemarkus Exp $
+
+*xdebug-client-2.1.1 (28 Mar 2011)
+
+ 28 Mar 2011; <olemarkus@gentoo.org> +xdebug-client-2.1.1.ebuild:
+ Version bump
28 Mar 2011; <olemarkus@gentoo.org> -xdebug-client-2.0.2.ebuild,
-xdebug-client-2.0.3.ebuild, -xdebug-client-2.0.5.ebuild,
diff --git a/dev-php/xdebug-client/xdebug-client-2.1.1.ebuild b/dev-php/xdebug-client/xdebug-client-2.1.1.ebuild
new file mode 100644
index 000000000000..8adce4c35d42
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.1.1.ebuild,v 1.1 2011/03/28 17:00:40 olemarkus Exp $
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( dev-libs/libedit )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}"/configure
+}
+
+src_compile() {
+ econf $(use_with libedit) --disable-dependency-tracking
+ emake || die "Build of debug client failed!"
+}
+
+src_install() {
+ newbin debugclient xdebug
+}