summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-01 20:20:46 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-01 20:20:46 +0000
commitb8a44f0173f381d289cc23575e823f9351dfa58a (patch)
tree696c4a8ba477d04e2c5a4d8f77a49004152e775d /dev-php
parentBump dev-python/pygments to 1.2. (diff)
downloadgentoo-2-b8a44f0173f381d289cc23575e823f9351dfa58a.tar.gz
gentoo-2-b8a44f0173f381d289cc23575e823f9351dfa58a.tar.bz2
gentoo-2-b8a44f0173f381d289cc23575e823f9351dfa58a.zip
Version bump. Fixes bug 256080.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug-client/ChangeLog9
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.0.5.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index a970b5abee37..2bcfe5631f92 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/xdebug-client
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.13 2008/07/15 18:21:46 jer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.14 2010/01/01 20:20:46 yngwin Exp $
+
+*xdebug-client-2.0.5 (01 Jan 2010)
+
+ 01 Jan 2010; Ben de Groot <yngwin@gentoo.org> +xdebug-client-2.0.5.ebuild:
+ Version bump. Fixes bug 256080.
15 Jul 2008; Jeroen Roovers <jer@gentoo.org> xdebug-client-2.0.3.ebuild:
Marked ~hppa too.
diff --git a/dev-php/xdebug-client/xdebug-client-2.0.5.ebuild b/dev-php/xdebug-client/xdebug-client-2.0.5.ebuild
new file mode 100644
index 000000000000..4d1b4f8028e2
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.0.5.ebuild,v 1.1 2010/01/01 20:20:46 yngwin Exp $
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( || ( dev-libs/libedit sys-freebsd/freebsd-lib ) )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}"/configure
+}
+
+src_compile() {
+ econf $(use_with libedit) --disable-dependency-tracking
+ emake || die "Build of debug client failed!"
+}
+
+src_install() {
+ newbin debugclient xdebug
+}