summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2012-09-02 14:42:23 +0000
committerMatti Bickel <mabi@gentoo.org>2012-09-02 14:42:23 +0000
commitad6d83c9e1cd4039a5ec3b509144311fe0ea9aac (patch)
treed55c54d9c28b6f34a83e33e88a127c57a125452a /dev-php
parentremove old (diff)
downloadgentoo-2-ad6d83c9e1cd4039a5ec3b509144311fe0ea9aac.tar.gz
gentoo-2-ad6d83c9e1cd4039a5ec3b509144311fe0ea9aac.tar.bz2
gentoo-2-ad6d83c9e1cd4039a5ec3b509144311fe0ea9aac.zip
remove old
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/jpgraph/ChangeLog5
-rw-r--r--dev-php/jpgraph/jpgraph-2.3.ebuild90
2 files changed, 4 insertions, 91 deletions
diff --git a/dev-php/jpgraph/ChangeLog b/dev-php/jpgraph/ChangeLog
index de756bb6222d..b7be1e7ff21e 100644
--- a/dev-php/jpgraph/ChangeLog
+++ b/dev-php/jpgraph/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-php/jpgraph
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/jpgraph/ChangeLog,v 1.28 2012/08/21 07:39:47 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/jpgraph/ChangeLog,v 1.29 2012/09/02 14:42:23 mabi Exp $
+
+ 02 Sep 2012; Matti Bickel <mabi@gentoo.org> -jpgraph-2.3.ebuild:
+ remove old
21 Aug 2012; Michael Weber <xmw@gentoo.org> jpgraph-3.0.7-r1.ebuild:
ppc stable (303745)
diff --git a/dev-php/jpgraph/jpgraph-2.3.ebuild b/dev-php/jpgraph/jpgraph-2.3.ebuild
deleted file mode 100644
index dd130a1ee03f..000000000000
--- a/dev-php/jpgraph/jpgraph-2.3.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/jpgraph/jpgraph-2.3.ebuild,v 1.1 2011/04/09 19:21:37 olemarkus Exp $
-
-inherit php-lib-r1 eutils
-
-KEYWORDS="alpha amd64 hppa ppc sparc x86"
-
-DESCRIPTION="Fully OO graph drawing library for PHP."
-HOMEPAGE="http://www.aditus.nu/jpgraph/"
-SRC_URI="http://hem.bredband.net/jpgraph2/${P}.tar.gz"
-LICENSE="QPL-1.0"
-SLOT="0"
-IUSE="truetype"
-
-DEPEND=""
-RDEPEND="truetype? ( media-fonts/corefonts )"
-
-need_php_by_category
-
-[[ -z "${JPGRAPH_CACHEDIR}" ]] && JPGRAPH_CACHEDIR="/var/cache/jpgraph-php5/"
-
-pkg_setup() {
- has_php
-
- # we need the PHP GD functionality
- require_gd
-
- # check to wich user:group the cache dir will go
- if has_version "www-servers/apache" ; then
- HTTPD_USER="apache"
- HTTPD_GROUP="apache"
- einfo "Configuring ${JPGRAPH_CACHEDIR} for Apache."
- else
- HTTPD_USER="${HTTPD_USER:-root}"
- HTTPD_GROUP="${HTTPD_GROUP:-root}"
- ewarn "No Apache webserver detected - ${JPGRAPH_CACHEDIR} will be"
- ewarn "owned by ${HTTPD_USER}:${HTTPD_GROUP} instead."
- ewarn "It this is not what you want, you can define"
- ewarn "HTTPD_USER and HTTPD_GROUP variables and re-emerge ${PN}."
- epause 3
- fi
-}
-
-src_install() {
- # some patches to adapt the config to Gentoo
- einfo "Patching jpg-config.inc.php"
-
- # patch 1:
- # make jpgraph use the correct group for file permissions
-
- sed -i "s|^DEFINE(\"CACHE_FILE_GROUP\",\"wwwadmin\");|DEFINE(\"CACHE_FILE_GROUP\",\"${HTTPD_GROUP}\");|" src/jpg-config.inc.php \
- || die "sed failed in patch 1"
-
- # patch 2:
- # make jpgraph use the correct directory for caching
-
- sed -i "s|.*DEFINE(\"CACHE_DIR\",\"/tmp/jpgraph_cache/\");|DEFINE(\"CACHE_DIR\",\"${JPGRAPH_CACHEDIR}\");|" src/jpg-config.inc.php \
- || die "sed failed in patch 2"
-
- # patch 3:
- # make jpgraph use the correct directory for the corefonts if the truetype USE flag is set
-
- if use truetype ; then
- sed -i "s|.*DEFINE(\"TTF_DIR\",\"/usr/X11R6/lib/X11/fonts/truetype/\");|DEFINE(\"TTF_DIR\",\"/usr/share/fonts/corefonts/\");|" src/jpg-config.inc.php \
- || die "sed failed in patch 3"
- fi
-
- # patch 4:
- # disable READ_CACHE in jpgraph
-
- sed -i "s|^DEFINE(\"READ_CACHE\",true);|DEFINE(\"READ_CACHE\",false);|" src/jpg-config.inc.php \
- || die "sed failed in patch 4"
-
- # install php files
- einfo "Building list of files to install"
- php-lib-r1_src_install src `cd src ; find . -type f -print`
-
- # install documentation
- einfo "Installing documentation"
- dodoc-php README
- insinto /usr/share/doc/${CATEGORY}/${PF}
- doins -r docs/*
-
- # setup the cache dir
- einfo "Setting up the cache dir"
- keepdir "${JPGRAPH_CACHEDIR}"
- fowners ${HTTPD_USER}:${HTTPD_GROUP} "${JPGRAPH_CACHEDIR}"
- fperms 750 "${JPGRAPH_CACHEDIR}"
-}