summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-08-07 08:39:03 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-08-07 08:39:03 +0000
commita7cfb0407838a4eeb7b3549f52bce70abf50a858 (patch)
tree0dc539de4ff26e62e6cd177e722fd996d743107d /dev-php
parentRevision bump. Apply fix for python 3 (bug #426428, patch from Debian). Add m... (diff)
downloadgentoo-2-a7cfb0407838a4eeb7b3549f52bce70abf50a858.tar.gz
gentoo-2-a7cfb0407838a4eeb7b3549f52bce70abf50a858.tar.bz2
gentoo-2-a7cfb0407838a4eeb7b3549f52bce70abf50a858.zip
Version bump
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-memcached/ChangeLog8
-rw-r--r--dev-php/pecl-memcached/pecl-memcached-2.1.0.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-php/pecl-memcached/ChangeLog b/dev-php/pecl-memcached/ChangeLog
index 4782ee6bd386..4b1fb06087df 100644
--- a/dev-php/pecl-memcached/ChangeLog
+++ b/dev-php/pecl-memcached/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/pecl-memcached
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcached/ChangeLog,v 1.4 2012/03/03 15:01:24 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcached/ChangeLog,v 1.5 2012/08/07 08:39:03 olemarkus Exp $
+
+*pecl-memcached-2.1.0 (07 Aug 2012)
+
+ 07 Aug 2012; Ole Markus With <olemarkus@gentoo.org>
+ +pecl-memcached-2.1.0.ebuild:
+ Version bump
*pecl-memcached-2.0.1 (03 Mar 2012)
diff --git a/dev-php/pecl-memcached/pecl-memcached-2.1.0.ebuild b/dev-php/pecl-memcached/pecl-memcached-2.1.0.ebuild
new file mode 100644
index 000000000000..507c5b7b4c5d
--- /dev/null
+++ b/dev-php/pecl-memcached/pecl-memcached-2.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcached/pecl-memcached-2.1.0.ebuild,v 1.1 2012/08/07 08:39:03 olemarkus Exp $
+
+EAPI="4"
+PHP_EXT_NAME="memcached"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+USE_PHP="php5-3 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension for interfacing with memcached via libmemcached library"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="+session igbinary"
+
+DEPEND=">=dev-libs/libmemcached-0.38 sys-libs/zlib
+ dev-lang/php[session?]
+ igbinary? ( dev-php/igbinary[php_targets_php5-4?,php_targets_php5-3?] )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ my_conf="--enable-memcached
+ --with-zlib-dir=/usr
+ $(use_enable session memcached-session)
+ $(use_enable igbinary memcached-igbinary)"
+
+ php-ext-source-r2_src_configure
+}