summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-09-11 14:19:39 +0000
committerMatti Bickel <mabi@gentoo.org>2010-09-11 14:19:39 +0000
commita71df55d5d923f753a1235c9f6b43b6d3260625e (patch)
tree6ed5236922682d9517fd9fa5b9eca93ca1f0d570 /dev-php
parentVersion bump (diff)
downloadgentoo-2-a71df55d5d923f753a1235c9f6b43b6d3260625e.tar.gz
gentoo-2-a71df55d5d923f753a1235c9f6b43b6d3260625e.tar.bz2
gentoo-2-a71df55d5d923f753a1235c9f6b43b6d3260625e.zip
use has_version instead of built_with_use
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Auth/ChangeLog8
-rw-r--r--dev-php/PEAR-Auth/PEAR-Auth-1.6.1.ebuild30
-rw-r--r--dev-php/PEAR-Auth/PEAR-Auth-1.6.2-r1.ebuild (renamed from dev-php/PEAR-Auth/PEAR-Auth-1.6.2.ebuild)9
3 files changed, 11 insertions, 36 deletions
diff --git a/dev-php/PEAR-Auth/ChangeLog b/dev-php/PEAR-Auth/ChangeLog
index ee8ac8ab0e33..d6263d8d7c8f 100644
--- a/dev-php/PEAR-Auth/ChangeLog
+++ b/dev-php/PEAR-Auth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/PEAR-Auth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Auth/ChangeLog,v 1.43 2010/02/16 04:25:25 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Auth/ChangeLog,v 1.44 2010/09/11 14:19:39 mabi Exp $
+
+*PEAR-Auth-1.6.2-r1 (11 Sep 2010)
+
+ 11 Sep 2010; Matti Bickel <mabi@gentoo.org> -PEAR-Auth-1.6.1.ebuild,
+ -PEAR-Auth-1.6.2.ebuild, +PEAR-Auth-1.6.2-r1.ebuild:
+ use has_version instead of built_with_use
*PEAR-Auth-1.6.2 (16 Feb 2010)
diff --git a/dev-php/PEAR-Auth/PEAR-Auth-1.6.1.ebuild b/dev-php/PEAR-Auth/PEAR-Auth-1.6.1.ebuild
deleted file mode 100644
index 45ae6ac13dd4..000000000000
--- a/dev-php/PEAR-Auth/PEAR-Auth-1.6.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Auth/PEAR-Auth-1.6.1.ebuild,v 1.1 2009/08/22 22:30:46 beandog Exp $
-
-inherit php-pear-r1 depend.php eutils
-
-DESCRIPTION="Provides methods for creating an authentication system using PHP."
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="minimal"
-RDEPEND="!minimal? ( >=dev-php/PEAR-Log-1.9.10
- >=dev-php/PEAR-File_Passwd-1.1.0
- >=dev-php/PEAR-Net_POP3-1.3.0
- >=dev-php/PEAR-DB-1.7.6-r1
- dev-php/PEAR-MDB
- >=dev-php/PEAR-MDB2-2.0.0_rc1
- >=dev-php/PEAR-Crypt_CHAP-1.0.0
- >=dev-php/PEAR-SOAP-0.9.0
- >=dev-php/PEAR-File_SMBPasswd-1.0.0 )"
- # missing lots of keywords
- # >=dev-php/PEAR-HTTP_Client-1.1.0
-
-pkg_postinst() {
- has_php
- if ! use minimal && ! built_with_use --missing true =${PHP_PKG} imap soap ; then
- elog "${PN} can optionally use ${PHP_PKG} imap and soap features."
- elog "If you want those, recompile ${PHP_PKG} with these flags in USE."
- fi
-}
diff --git a/dev-php/PEAR-Auth/PEAR-Auth-1.6.2.ebuild b/dev-php/PEAR-Auth/PEAR-Auth-1.6.2-r1.ebuild
index f22ffbcd28f8..3f08a2832bd8 100644
--- a/dev-php/PEAR-Auth/PEAR-Auth-1.6.2.ebuild
+++ b/dev-php/PEAR-Auth/PEAR-Auth-1.6.2-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Auth/PEAR-Auth-1.6.2.ebuild,v 1.1 2010/02/16 04:25:25 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Auth/PEAR-Auth-1.6.2-r1.ebuild,v 1.1 2010/09/11 14:19:39 mabi Exp $
-inherit php-pear-r1 depend.php eutils
+inherit php-pear-r1 eutils
DESCRIPTION="Provides methods for creating an authentication system using PHP."
LICENSE="PHP-3.01"
@@ -22,9 +22,8 @@ RDEPEND="!minimal? ( >=dev-php/PEAR-Log-1.9.10
# >=dev-php/PEAR-HTTP_Client-1.1.0
pkg_postinst() {
- has_php
- if ! use minimal && ! built_with_use --missing true =${PHP_PKG} imap soap ; then
- elog "${PN} can optionally use ${PHP_PKG} imap and soap features."
+ if ! use minimal && ! has_version "${PHP_PKG}[imap,soap]" ; then
+ elog "${PN} can optionally use php's imap and soap features."
elog "If you want those, recompile ${PHP_PKG} with these flags in USE."
fi
}