summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-08-08 15:25:46 +0000
committerMatti Bickel <mabi@gentoo.org>2010-08-08 15:25:46 +0000
commita447b3c3f5c1a056cb0c573d0a16071d1dea6beb (patch)
tree71f5696e28d0e6b2a32e802c6b7482323ee43b3f /dev-php
parentRemoved deathwing00 from metadata as he took an extended away. (diff)
downloadgentoo-2-a447b3c3f5c1a056cb0c573d0a16071d1dea6beb.tar.gz
gentoo-2-a447b3c3f5c1a056cb0c573d0a16071d1dea6beb.tar.bz2
gentoo-2-a447b3c3f5c1a056cb0c573d0a16071d1dea6beb.zip
bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug-client/ChangeLog7
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.1.0.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index d19111190eb3..01c99ba1bbd4 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/xdebug-client
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.17 2010/06/13 14:36:14 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.18 2010/08/08 15:25:46 mabi Exp $
+
+*xdebug-client-2.1.0 (08 Aug 2010)
+
+ 08 Aug 2010; Matti Bickel <mabi@gentoo.org> +xdebug-client-2.1.0.ebuild:
+ version bump (bug #331353)
13 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
xdebug-client-2.0.5.ebuild:
diff --git a/dev-php/xdebug-client/xdebug-client-2.1.0.ebuild b/dev-php/xdebug-client/xdebug-client-2.1.0.ebuild
new file mode 100644
index 000000000000..85de531fa4ac
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.1.0.ebuild,v 1.1 2010/08/08 15:25:46 mabi Exp $
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( dev-libs/libedit )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}"/configure
+}
+
+src_compile() {
+ econf $(use_with libedit) --disable-dependency-tracking
+ emake || die "Build of debug client failed!"
+}
+
+src_install() {
+ newbin debugclient xdebug
+}