summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-07-19 06:25:20 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-07-19 06:25:20 +0000
commita2d92f13b25d9ada08febd23a7ee276ed042ad9b (patch)
tree5baa2864d4e467df94e661359bc5364c8118d537 /dev-php
parentRemove broken version. (diff)
downloadgentoo-2-a2d92f13b25d9ada08febd23a7ee276ed042ad9b.tar.gz
gentoo-2-a2d92f13b25d9ada08febd23a7ee276ed042ad9b.tar.bz2
gentoo-2-a2d92f13b25d9ada08febd23a7ee276ed042ad9b.zip
Update live ebuild for proper multi-slot building.
(Portage version: 2.1.11.8/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/libvirt-php/ChangeLog8
-rw-r--r--dev-php/libvirt-php/libvirt-php-9999.ebuild20
2 files changed, 21 insertions, 7 deletions
diff --git a/dev-php/libvirt-php/ChangeLog b/dev-php/libvirt-php/ChangeLog
index 3c97aab81818..fcc5fea65197 100644
--- a/dev-php/libvirt-php/ChangeLog
+++ b/dev-php/libvirt-php/ChangeLog
@@ -1,6 +1,9 @@
-# ChangeLog for dev-php5/libvirt-php
+# ChangeLog for dev-php/libvirt-php
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/libvirt-php/ChangeLog,v 1.2 2012/01/15 17:14:31 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/libvirt-php/ChangeLog,v 1.3 2012/07/19 06:25:20 dev-zero Exp $
+
+ 19 Jul 2012; Tiziano Müller <dev-zero@gentoo.org> libvirt-php-9999.ebuild:
+ Update live ebuild for proper multi-slot building.
15 Jan 2012; Ole Markus With <olemarkus@gentoo.org> libvirt-php-0.4.1.ebuild,
libvirt-php-9999.ebuild:
@@ -29,4 +32,3 @@
+libvirt-php-9999.ebuild, +metadata.xml:
Initial commit (ebuild written by me). Added php as herd as discussed with
Ole Markus.
-
diff --git a/dev-php/libvirt-php/libvirt-php-9999.ebuild b/dev-php/libvirt-php/libvirt-php-9999.ebuild
index f84ad0cc75cd..47e3abea77c6 100644
--- a/dev-php/libvirt-php/libvirt-php-9999.ebuild
+++ b/dev-php/libvirt-php/libvirt-php-9999.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/libvirt-php/libvirt-php-9999.ebuild,v 1.2 2012/01/15 17:14:31 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/libvirt-php/libvirt-php-9999.ebuild,v 1.3 2012/07/19 06:25:20 dev-zero Exp $
-EAPI=3
+EAPI=4
PHP_EXT_NAME="libvirt-php"
+PHP_EXT_SKIP_PHPIZE="yes"
+USE_PHP="php5-3 php5-4"
inherit php-ext-source-r2 git-2
@@ -22,10 +24,14 @@ RDEPEND="app-emulation/libvirt
DEPEND="${DEPEND}
doc? ( app-text/xhtml1 dev-libs/libxslt )"
+RESTRICT="test"
+
+EGIT_BOOTSTRAP="autogen.sh"
+
src_unpack() {
git-2_src_unpack
# create the default modules directory to be able
- # to use the php-ext-source-r2 eclass to install
+ # to use the php-ext-source-r2 eclass to configure/build
ln -s src "${S}/modules"
for slot in $(php_get_slots); do
@@ -34,6 +40,12 @@ src_unpack() {
}
src_install() {
- php-ext-source-r2_src_install
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ insinto "${EXT_DIR}"
+ newins "src/${PHP_EXT_NAME}.so" "${PHP_EXT_NAME}.so"
+ done
+ php-ext-source-r2_createinifiles
+ dodoc AUTHORS ChangeLog NEWS README
use doc && dohtml docs/* docs/graphics/*
}