summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2008-01-18 12:21:23 +0000
committerMarijn Schouten <hkbst@gentoo.org>2008-01-18 12:21:23 +0000
commit8a34eb7bc8225c2f2c13269948d99d8e95bb73ba (patch)
tree2ee5a930f798a82ebf67e1643790cb7a68cb17f4 /dev-php
parentRemove mask entries for net-irc/audacious-show and media-plugins/audacious-do... (diff)
downloadgentoo-2-8a34eb7bc8225c2f2c13269948d99d8e95bb73ba.tar.gz
gentoo-2-8a34eb7bc8225c2f2c13269948d99d8e95bb73ba.tar.bz2
gentoo-2-8a34eb7bc8225c2f2c13269948d99d8e95bb73ba.zip
bump
(Portage version: 2.1.4)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/roadsend-php/ChangeLog8
-rw-r--r--dev-php/roadsend-php/files/digest-roadsend-php-2.9.43
-rw-r--r--dev-php/roadsend-php/roadsend-php-2.9.4.ebuild50
3 files changed, 60 insertions, 1 deletions
diff --git a/dev-php/roadsend-php/ChangeLog b/dev-php/roadsend-php/ChangeLog
index 1980c1ea90e0..546c6ee2c91b 100644
--- a/dev-php/roadsend-php/ChangeLog
+++ b/dev-php/roadsend-php/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/roadsend-php
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/roadsend-php/ChangeLog,v 1.4 2008/01/01 18:00:30 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/roadsend-php/ChangeLog,v 1.5 2008/01/18 12:21:22 hkbst Exp $
+
+*roadsend-php-2.9.4 (18 Jan 2008)
+
+ 18 Jan 2008; Marijn Schouten <hkBst@gentoo.org>
+ +roadsend-php-2.9.4.ebuild:
+ bump
*roadsend-php-2.9.3 (01 Jan 2008)
diff --git a/dev-php/roadsend-php/files/digest-roadsend-php-2.9.4 b/dev-php/roadsend-php/files/digest-roadsend-php-2.9.4
new file mode 100644
index 000000000000..b341e329725f
--- /dev/null
+++ b/dev-php/roadsend-php/files/digest-roadsend-php-2.9.4
@@ -0,0 +1,3 @@
+MD5 7a1fb5bb87e2e06d500a271ee169f4c3 roadsend-php-2.9.4.tar.bz2 2841981
+RMD160 5b4b4ce98fd7ab24e31e2c128edd7a72fd7c3039 roadsend-php-2.9.4.tar.bz2 2841981
+SHA256 3dd197c36a08143b8f87d2237d84f7ac063c0c1e15686e2e2b5a4f9ef3ce875b roadsend-php-2.9.4.tar.bz2 2841981
diff --git a/dev-php/roadsend-php/roadsend-php-2.9.4.ebuild b/dev-php/roadsend-php/roadsend-php-2.9.4.ebuild
new file mode 100644
index 000000000000..8c26ceede2da
--- /dev/null
+++ b/dev-php/roadsend-php/roadsend-php-2.9.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/roadsend-php/roadsend-php-2.9.4.ebuild,v 1.1 2008/01/18 12:21:22 hkbst Exp $
+
+MY_PVL=${PV/_p/-r}
+MY_PV=${PV%%_p[0-9]}
+MY_PL=${PN}-${MY_PVL}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Roadsend PHP compiler"
+HOMEPAGE="http://code.roadsend.com/pcc"
+SRC_URI="http://code.roadsend.com/snaps/${MY_PL}.tar.bz2"
+LICENSE="GPL-2 LGPL-2.1"
+
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-scheme/bigloo-3.0c
+ >=net-misc/curl-7.15.1-r1
+ mysql? ( dev-db/mysql )
+ sqlite3? ( >=dev-db/sqlite-3.3.12 )
+ pcre? ( >=dev-libs/libpcre-6.6 )
+ xml? ( dev-libs/libxml2 )
+ odbc? ( dev-db/unixODBC )
+ fastcgi? ( dev-libs/fcgi )"
+
+RDEPEND="${DEPEND}"
+SLOT="0"
+
+IUSE="debug fastcgi mysql odbc pcre sqlite3 xml"
+#IUSE="fastcgi mysql odbc pcre sqlite3 xml"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_with pcre) $(use_with fastcgi fcgi) $(use_with xml) $(use_with mysql) $(use_with sqlite3) $(use_with odbc)
+
+ if use debug; then
+ emake -j1 || die "make debug failed"
+ else
+ emake -j1 unsafe || die "make failed"
+ fi
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/libs/" emake -j1 test || die "standalone tests failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+}