summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2012-08-05 19:46:59 +0000
committerMatti Bickel <mabi@gentoo.org>2012-08-05 19:46:59 +0000
commit8511d563559c672a6e126dd8850a15bebd056874 (patch)
tree146c0c100883227b5c601b1a14df305fc00eea37 /dev-php
parentfix for wrong detected *.pot file in po dir (diff)
downloadgentoo-2-8511d563559c672a6e126dd8850a15bebd056874.tar.gz
gentoo-2-8511d563559c672a6e126dd8850a15bebd056874.tar.bz2
gentoo-2-8511d563559c672a6e126dd8850a15bebd056874.zip
version bump & remove old
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Net_Server/ChangeLog9
-rw-r--r--dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.2.ebuild24
-rw-r--r--dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.3.ebuild23
3 files changed, 30 insertions, 26 deletions
diff --git a/dev-php/PEAR-Net_Server/ChangeLog b/dev-php/PEAR-Net_Server/ChangeLog
index 09137371f1c0..9cdfa4f39aae 100644
--- a/dev-php/PEAR-Net_Server/ChangeLog
+++ b/dev-php/PEAR-Net_Server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/PEAR-Net_Server
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Net_Server/ChangeLog,v 1.34 2012/08/05 18:21:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Net_Server/ChangeLog,v 1.35 2012/08/05 19:46:59 mabi Exp $
+
+*PEAR-Net_Server-1.0.3 (05 Aug 2012)
+
+ 05 Aug 2012; Matti Bickel <mabi@gentoo.org> +PEAR-Net_Server-1.0.3.ebuild,
+ -PEAR-Net_Server-1.0.2.ebuild:
+ version bump & remove old
05 Aug 2012; Raúl Porcel <armin76@gentoo.org>
PEAR-Net_Server-1.0.2-r1.ebuild:
@@ -148,4 +154,3 @@
02 Jul 2005; Sebastian Bergmann <sebastian@gentoo.org> +metadata.xml,
+PEAR-Net_Server-0.12.0.ebuild:
Initial ebuild, closes bug 96058.
-
diff --git a/dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.2.ebuild b/dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.2.ebuild
deleted file mode 100644
index a247ac29802d..000000000000
--- a/dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.2.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.2.ebuild,v 1.9 2007/12/06 00:41:57 jokey Exp $
-
-inherit php-pear-r1 depend.php eutils
-
-DESCRIPTION="Generic server class for PHP."
-
-LICENSE="PHP-2.02"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-pkg_setup() {
- require_php_with_use sockets
-}
-
-pkg_postinst() {
- has_php
- if ! built_with_use --missing true =${PHP_PKG} pcntl ; then
- elog "${PN} can optionally use ${PHP_PKG} pcntl features."
- elog "If you want those, recompile ${PHP_PKG} with this flag in USE."
- fi
-}
diff --git a/dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.3.ebuild b/dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.3.ebuild
new file mode 100644
index 000000000000..1c6ca3376793
--- /dev/null
+++ b/dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Net_Server/PEAR-Net_Server-1.0.3.ebuild,v 1.1 2012/08/05 19:46:59 mabi Exp $
+
+EAPI="4"
+
+inherit php-pear-r1
+
+DESCRIPTION="Generic server class for PHP."
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/php[sockets]"
+
+pkg_postinst() {
+ if ! has_version "dev-lang/php[pcntl]" ; then
+ elog "${PN} can optionally use dev-lang/php pcntl features."
+ elog "If you want those, recompile dev-lang/php with this flag in USE."
+ fi
+}