summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-03-07 08:53:50 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-03-07 08:53:50 +0000
commit78ab112a077491b02143d6040416d595eeecf9b2 (patch)
treeca09163d2e398f9da5fdcb67449d95e2e8e8fab8 /dev-php
parentClean up old revision. (diff)
downloadgentoo-2-78ab112a077491b02143d6040416d595eeecf9b2.tar.gz
gentoo-2-78ab112a077491b02143d6040416d595eeecf9b2.tar.bz2
gentoo-2-78ab112a077491b02143d6040416d595eeecf9b2.zip
Version bump
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-http/ChangeLog7
-rw-r--r--dev-php/pecl-http/pecl-http-1.7.5.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-php/pecl-http/ChangeLog b/dev-php/pecl-http/ChangeLog
index 1de0cea38930..51d88a14574f 100644
--- a/dev-php/pecl-http/ChangeLog
+++ b/dev-php/pecl-http/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/pecl-http
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-http/ChangeLog,v 1.11 2013/03/05 11:17:01 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-http/ChangeLog,v 1.12 2013/03/07 08:53:50 olemarkus Exp $
+
+*pecl-http-1.7.5 (07 Mar 2013)
+
+ 07 Mar 2013; Ole Markus With <olemarkus@gentoo.org> +pecl-http-1.7.5.ebuild:
+ Version bump
05 Mar 2013; Ole Markus With <olemarkus@gentoo.org>
-pecl-http-1.7.0-r1.ebuild, -pecl-http-1.7.1.ebuild,
diff --git a/dev-php/pecl-http/pecl-http-1.7.5.ebuild b/dev-php/pecl-http/pecl-http-1.7.5.ebuild
new file mode 100644
index 000000000000..e5a71c685342
--- /dev/null
+++ b/dev-php/pecl-http/pecl-http-1.7.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-http/pecl-http-1.7.5.ebuild,v 1.1 2013/03/07 08:53:50 olemarkus Exp $
+
+EAPI="5"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="docs/examples/tutorial.txt ThanksTo.txt KnownIssues.txt"
+
+USE_PHP="php5-3 php5-4"
+
+inherit php-ext-pecl-r2 php-ext-source-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP."
+LICENSE="BSD-2 MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="net-misc/curl
+ sys-libs/zlib
+ dev-libs/libevent
+ dev-lang/php[hash,session,iconv]
+ "
+RDEPEND="${DEPEND}"
+
+my_conf="--enable-http \
+ --with-http-curl-requests \
+ --with-http-zlib-compression \
+ --with-http-curl-libevent \
+ --with-http-magic-mime"
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "http.etag.mode" "MD5"
+ php-ext-source-r2_addtoinifiles "http.force_exit" "1"
+ php-ext-source-r2_addtoinifiles "http.log.allowed_methods" ""
+ php-ext-source-r2_addtoinifiles "http.log.cache" ""
+ php-ext-source-r2_addtoinifiles "http.log.composite" ""
+ php-ext-source-r2_addtoinifiles "http.log.not_found" ""
+ php-ext-source-r2_addtoinifiles "http.log.redirect" ""
+ php-ext-source-r2_addtoinifiles "http.only_exceptions" "0"
+ php-ext-source-r2_addtoinifiles "http.persistent.handles.ident" "GLOBAL"
+ php-ext-source-r2_addtoinifiles "http.persistent.handles.limit" "-1"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.connect" "0"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.cookie" "0"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.dns" "1"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.ssl" "0"
+ php-ext-source-r2_addtoinifiles "http.request.methods.allowed" ""
+ php-ext-source-r2_addtoinifiles "http.request.methods.custom" ""
+ php-ext-source-r2_addtoinifiles "http.send.inflate.start_auto" "0"
+ php-ext-source-r2_addtoinifiles "http.send.inflate.start_flags" "0"
+ php-ext-source-r2_addtoinifiles "http.send.deflate.start_auto" "0"
+ php-ext-source-r2_addtoinifiles "http.send.deflate.start_flags" "0"
+ php-ext-source-r2_addtoinifiles "http.send.not_found_404" "1"
+}