summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2004-03-21 18:17:51 +0000
committerTom William Payne <twp@gentoo.org>2004-03-21 18:17:51 +0000
commit6334f7f8ec601395a700c2cfea7e45a46532af62 (patch)
tree47e3624ab7b74300082efbdd83c59749724b2410 /dev-php
parentadded ~amd64 to keywords (Manifest recommit) (diff)
downloadgentoo-2-6334f7f8ec601395a700c2cfea7e45a46532af62.tar.gz
gentoo-2-6334f7f8ec601395a700c2cfea7e45a46532af62.tar.bz2
gentoo-2-6334f7f8ec601395a700c2cfea7e45a46532af62.zip
Version bump. Add docs if USE=doc. Bug #43905.
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/smarty/ChangeLog7
-rw-r--r--dev-php/smarty/Manifest2
-rw-r--r--dev-php/smarty/files/digest-smarty-2.6.21
-rw-r--r--dev-php/smarty/smarty-2.6.2.ebuild28
4 files changed, 37 insertions, 1 deletions
diff --git a/dev-php/smarty/ChangeLog b/dev-php/smarty/ChangeLog
index 803191e768d0..4e424aade02f 100644
--- a/dev-php/smarty/ChangeLog
+++ b/dev-php/smarty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/smarty
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.9 2004/01/08 08:39:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.10 2004/03/21 18:17:51 twp Exp $
+
+*smarty-2.6.2 (21 Mar 2004)
+
+ 21 Mar 2004; Tom Payne <twp@gentoo.org> smarty-2.6.2.ebuild :
+ Version bump. Add docs if USE=doc. Bug #43905.
08 Jan 2004; Robin H. Johnson <robbat2@gentoo.org> smarty-2.5.0.ebuild,
smarty-2.6.0-r1.ebuild, smarty-2.6.0-r2.ebuild, smarty-2.6.0.ebuild:
diff --git a/dev-php/smarty/Manifest b/dev-php/smarty/Manifest
index 2b366c1f9f38..e4e710aba8d0 100644
--- a/dev-php/smarty/Manifest
+++ b/dev-php/smarty/Manifest
@@ -1,3 +1,4 @@
+MD5 cc80be03d90431ed1d2284ddb2ce1d09 smarty-2.6.2.ebuild 914
MD5 a251567049244b3ea32a8ca6f486700b smarty-2.6.0-r2.ebuild 881
MD5 3cadf70b1718e24f38dd2477a9f947e7 smarty-2.5.0.ebuild 992
MD5 fdcf1faaa3746c2724544d4f01216588 smarty-2.6.0-r1.ebuild 866
@@ -6,5 +7,6 @@ MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
MD5 ea4f8acaf24923f8c0a8fb52561908d7 smarty-2.6.0.ebuild 992
MD5 74ae938ca9097670a89c5f2ff6ad28f8 files/digest-smarty-2.5.0 133
MD5 d682d64693190a83f04b9d51ee9d1bfe files/digest-smarty-2.6.0 133
+MD5 e4efdb7a0ff70439c7314f0f570ea9aa files/digest-smarty-2.6.2 64
MD5 cc746919357bf3d40185fb16d4e2be1c files/digest-smarty-2.6.0-r1 64
MD5 cc746919357bf3d40185fb16d4e2be1c files/digest-smarty-2.6.0-r2 64
diff --git a/dev-php/smarty/files/digest-smarty-2.6.2 b/dev-php/smarty/files/digest-smarty-2.6.2
new file mode 100644
index 000000000000..7d667f59ef58
--- /dev/null
+++ b/dev-php/smarty/files/digest-smarty-2.6.2
@@ -0,0 +1 @@
+MD5 876313391dcf6452e3867169230ec4d9 Smarty-2.6.2.tar.gz 125574
diff --git a/dev-php/smarty/smarty-2.6.2.ebuild b/dev-php/smarty/smarty-2.6.2.ebuild
new file mode 100644
index 000000000000..219a3493df71
--- /dev/null
+++ b/dev-php/smarty/smarty-2.6.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.2.ebuild,v 1.1 2004/03/21 18:17:51 twp Exp $
+
+MY_P=Smarty-${PV}
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="http://smarty.php.net/"
+SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~hppa ~ppc ~sparc ~x86"
+IUSE="doc"
+DEPEND="doc? ( dev-php/smarty-docs )"
+RDEPEND="virtual/php"
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dodoc [A-Z]*
+ mkdir -p ${D}/usr/lib/php
+ cp -a libs ${D}/usr/lib/php/Smarty
+}
+
+pkg_postinst() {
+ einfo "Smarty has been installed in /usr/lib/php/Smarty/."
+ einfo "To use it in your scripts, either"
+ einfo "1. define('SMARTY_DIR', \"/usr/lib/php/Smarty/\") in your scripts, or"
+ einfo "2. add /usr/lib/php/Smarty/ to includes= in /etc/php4/php.ini"
+}