summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-08-05 15:07:25 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-08-05 15:07:25 +0000
commit5adddcb631d603edc53761f211a932037408085d (patch)
tree61894eac702d5d92eba7ff25a75d16dbb14be319 /dev-php
parentkeyword amd64-linux, x86-linux, removed old (diff)
downloadgentoo-2-5adddcb631d603edc53761f211a932037408085d.tar.gz
gentoo-2-5adddcb631d603edc53761f211a932037408085d.tar.bz2
gentoo-2-5adddcb631d603edc53761f211a932037408085d.zip
Version bump
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xcache/ChangeLog7
-rw-r--r--dev-php/xcache/xcache-2.0.1.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/dev-php/xcache/ChangeLog b/dev-php/xcache/ChangeLog
index 04ae705c9c58..ba796eb3d541 100644
--- a/dev-php/xcache/ChangeLog
+++ b/dev-php/xcache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/xcache
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/ChangeLog,v 1.7 2012/05/09 07:36:24 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/ChangeLog,v 1.8 2012/08/05 15:07:25 olemarkus Exp $
+
+*xcache-2.0.1 (05 Aug 2012)
+
+ 05 Aug 2012; Ole Markus With <olemarkus@gentoo.org> +xcache-2.0.1.ebuild:
+ Version bump
09 May 2012; Zac Medico <zmedico@gentoo.org> xcache-2.0.0.ebuild:
Move EAPI assignment to top of ebuild, bug 411875.
diff --git a/dev-php/xcache/xcache-2.0.1.ebuild b/dev-php/xcache/xcache-2.0.1.ebuild
new file mode 100644
index 000000000000..099fc32a1be2
--- /dev/null
+++ b/dev-php/xcache/xcache-2.0.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/xcache-2.0.1.ebuild,v 1.1 2012/08/05 15:07:25 olemarkus Exp $
+
+EAPI="4"
+PHP_EXT_NAME="xcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+PHPSAPILIST="apache2 cgi fpm"
+
+USE_PHP="php5-3 php5-4"
+inherit php-ext-source-r2 confutils
+
+DESCRIPTION="A fast and stable PHP opcode cacher"
+HOMEPAGE="http://xcache.lighttpd.net/"
+SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# make test would just run php's test and as such need the full php source
+RESTRICT="test"
+
+DEPEND="virtual/httpd-php
+!dev-php/eaccelerator !dev-php/pecl-apc"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+
+ my_conf="--enable-xcache=shared \
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ --enable-xcache-coverager \
+ --enable-xcache-assembler \
+ --enable-xcache-encoder \
+ --enable-xcache-decoder"
+
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-source-r2_src_install
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+
+ php-ext-source-r2_addtoinifiles "xcache.admin.enable_auth" '"On"'
+ php-ext-source-r2_addtoinifiles "xcache.admin.user" '"admin"'
+ php-ext-source-r2_addtoinifiles "xcache.admin.pass" '""'
+
+ php-ext-source-r2_addtoinifiles "xcache.cacher" '"On"'
+ php-ext-source-r2_addtoinifiles "xcache.size" '"64M"'
+ php-ext-source-r2_addtoinifiles "xcache.count" '"2"'
+ php-ext-source-r2_addtoinifiles "xcache.slots" '"8k"'
+ php-ext-source-r2_addtoinifiles "xcache.ttl" '"0"'
+ php-ext-source-r2_addtoinifiles "xcache.gc_interval" '"0"'
+ php-ext-source-r2_addtoinifiles "xcache.var_size" '"8M"'
+ php-ext-source-r2_addtoinifiles "xcache.var_count" '"1"'
+ php-ext-source-r2_addtoinifiles "xcache.var_slots" '"8K"'
+ php-ext-source-r2_addtoinifiles "xcache.var_ttl" '"0"'
+ php-ext-source-r2_addtoinifiles "xcache.var_maxttl" '"0"'
+ php-ext-source-r2_addtoinifiles "xcache.var_gc_interval" '"600"'
+ php-ext-source-r2_addtoinifiles "xcache.readonly_protection" '"Off"'
+ php-ext-source-r2_addtoinifiles "xcache.mmap_path" '"/dev/zero"'
+
+ php-ext-source-r2_addtoinifiles "xcache.coverager" '"Off"'
+ php-ext-source-r2_addtoinifiles "xcache.coveragedump_directory" '""'
+
+ php-ext-source-r2_addtoinifiles "xcache.optimizer" '"Off"'
+
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins Decompiler.class.php
+ insinto "${PHP_EXT_SHARED_DIR}/admin"
+ doins admin/*
+ insinto "${PHP_EXT_SHARED_DIR}/coverager"
+ doins coverager/*
+}
+
+pkg_postinst() {
+ elog "Decompiler.class.php, the admin/ and the coverager/ directory shipped with this"
+ elog "release were installed into ${ROOT}usr/share/php5/xcache/."
+}