summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Knight <tomk@gentoo.org>2007-03-11 22:20:50 +0000
committerTom Knight <tomk@gentoo.org>2007-03-11 22:20:50 +0000
commit44c70ab785bd986557e13b3c3886fca55d648143 (patch)
tree05ddc3d131e1c624d7f692fd1a5c81e3c8551a67 /dev-php
parentbuild.xml + ebuild cleanups. (diff)
downloadgentoo-2-44c70ab785bd986557e13b3c3886fca55d648143.tar.gz
gentoo-2-44c70ab785bd986557e13b3c3886fca55d648143.tar.bz2
gentoo-2-44c70ab785bd986557e13b3c3886fca55d648143.zip
Version bump to 2.6.18, thanks to toto for reporting it, fixes bug #170113.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/smarty/ChangeLog7
-rw-r--r--dev-php/smarty/files/digest-smarty-2.6.183
-rw-r--r--dev-php/smarty/smarty-2.6.18.ebuild41
3 files changed, 50 insertions, 1 deletions
diff --git a/dev-php/smarty/ChangeLog b/dev-php/smarty/ChangeLog
index fbd202e2cce7..8e860bb9ebac 100644
--- a/dev-php/smarty/ChangeLog
+++ b/dev-php/smarty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/smarty
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.67 2007/01/28 06:27:38 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.68 2007/03/11 22:20:50 tomk Exp $
+
+*smarty-2.6.18 (11 Mar 2007)
+
+ 11 Mar 2007; Tom Knight <tomk@gentoo.org> +smarty-2.6.18.ebuild:
+ Version bump to 2.6.18, thanks to toto for reporting it, fixes bug #170113.
28 Jan 2007; Marius Mauch <genone@gentoo.org> smarty-2.6.14.ebuild,
smarty-2.6.16.ebuild:
diff --git a/dev-php/smarty/files/digest-smarty-2.6.18 b/dev-php/smarty/files/digest-smarty-2.6.18
new file mode 100644
index 000000000000..a1b383e8ed8f
--- /dev/null
+++ b/dev-php/smarty/files/digest-smarty-2.6.18
@@ -0,0 +1,3 @@
+MD5 cd9b9c78b43c0d0490b71111b2fe1a99 Smarty-2.6.18.tar.gz 153299
+RMD160 007c37fc8ab90756e35d00a45792e0ccfb5843da Smarty-2.6.18.tar.gz 153299
+SHA256 14830bffb17e0490f671f9ae3372e97c7182db261af19eea39c046139f177bf7 Smarty-2.6.18.tar.gz 153299
diff --git a/dev-php/smarty/smarty-2.6.18.ebuild b/dev-php/smarty/smarty-2.6.18.ebuild
new file mode 100644
index 000000000000..687afb6f2f03
--- /dev/null
+++ b/dev-php/smarty/smarty-2.6.18.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.18.ebuild,v 1.1 2007/03/11 22:20:50 tomk Exp $
+
+inherit php-lib-r1
+
+DESCRIPTION="A template engine for PHP."
+HOMEPAGE="http://smarty.php.net/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-php/smarty-docs )"
+
+MY_P="Smarty-${PV}"
+SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+need_php_by_category
+
+src_install() {
+ dodoc-php BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO
+ php-lib-r1_src_install ./libs `find ./libs -type f -print | sed -e "s|./libs||g"`
+}
+
+pkg_postinst() {
+ einfo "${PHP_LIB_NAME} has been installed in /usr/share/php/${PHP_LIB_NAME}/."
+ einfo "To use it in your scripts, either"
+ einfo "1. define('SMARTY_DIR', \"/usr/share/php/${PHP_LIB_NAME}/\") in your scripts, or"
+ einfo "2. add '/usr/share/php/${PHP_LIB_NAME}/' to the 'include_path' variable in your"
+ einfo "php.ini file under /etc/php/SAPI (where SAPI is one of apache-php[45],"
+ einfo "cgi-php[45] or cli-php[45])."
+ echo
+ einfo "If you're upgrading from a previous version make sure to clear out your"
+ einfo "templates_c and cache directories as some include paths have changed!"
+ echo
+ einfo "The Smarty include directory has changed in 2.6.12 from /usr/share/php/Smarty/"
+ einfo "to /usr/share/php/${PHP_LIB_NAME}/ you will need to change your SMARTY_DIR or"
+ einfo "include_path accordingly."
+}