summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-04-23 10:05:06 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-04-23 10:05:06 +0000
commit2d9eb079c5ec4497bdee75ebe13488b22fd35d55 (patch)
tree83da81d46a4eb2120845f93a663514ccb8354286 /dev-php
parentexperimental version for new PHP eclass (diff)
downloadgentoo-2-2d9eb079c5ec4497bdee75ebe13488b22fd35d55.tar.gz
gentoo-2-2d9eb079c5ec4497bdee75ebe13488b22fd35d55.tar.bz2
gentoo-2-2d9eb079c5ec4497bdee75ebe13488b22fd35d55.zip
experimental version for new PHP eclass
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/ChangeLog8
-rw-r--r--dev-php/mod_php/Manifest5
-rw-r--r--dev-php/mod_php/files/digest-mod_php-4.3.1-r31
-rw-r--r--dev-php/mod_php/mod_php-4.3.1-r3.ebuild100
-rw-r--r--dev-php/php/ChangeLog9
-rw-r--r--dev-php/php/Manifest6
-rw-r--r--dev-php/php/files/digest-php-4.3.1-r21
-rw-r--r--dev-php/php/files/pear_config.diff12
-rw-r--r--dev-php/php/php-4.3.1-r2.ebuild93
9 files changed, 227 insertions, 8 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index d0bb9aa375b1..2455145627db 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/mod_php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.58 2003/04/23 03:40:33 heim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.59 2003/04/23 10:04:57 robbat2 Exp $
+
+*mod_php-4.3.1-r3 (23 Apr 2003)
+
+ 23 Apr 2003; Robin H. Johnson <robbat2@gentoo.org> mod_php-4.3.1-r3.ebuild:
+ New version utilizing PHP eclass
+ Masked still, very untested
*mod_php-4.3.1-r2 (21 Apr 2003)
diff --git a/dev-php/mod_php/Manifest b/dev-php/mod_php/Manifest
index cc5ec72f4cd7..827b2cc100e7 100644
--- a/dev-php/mod_php/Manifest
+++ b/dev-php/mod_php/Manifest
@@ -1,10 +1,9 @@
-MD5 9265b53e4004a2c4658d2c86976270e3 mod_php-4.3.1-r3.ebuild 2745
+MD5 943f40908e087586336045d28e002b8c mod_php-4.3.1-r3.ebuild 2748
MD5 40e7c2563c18f1b091ef5fb26c4d59ed mod_php-4.3.1.ebuild 8688
MD5 904d1ba2927fae09ff0d9f8e12561317 mod_php-4.3.1-r2.ebuild 9128
MD5 6de98d80b82a71ed8845884b0bd5676e mod_php-4.2.3-r2.ebuild 8071
MD5 d470c7ff3d3a9d470e845eb240519982 mod_php-4.3.0-r2.ebuild 8635
-MD5 af59ccf297420d485eca1ea23000df39 ChangeLog 13983
-MD5 24a4ab98d3af5fcf49d9a27eec0a9558 mod_php-4.3.1-r3.ebuild~ 2747
+MD5 3aae7db3f07a3ebb36eea8eff467dae2 ChangeLog 14163
MD5 68f967fbb5cf7faabf563eb9f340da35 mod_php-4.3.1-r1.ebuild 8904
MD5 cceddd5c262e0ffef31d45b7da269851 files/mod_php.conf 148
MD5 6cf293d9a0faa0e7e5d86d9fd2d47131 files/70_mod_php.conf 329
diff --git a/dev-php/mod_php/files/digest-mod_php-4.3.1-r3 b/dev-php/mod_php/files/digest-mod_php-4.3.1-r3
new file mode 100644
index 000000000000..da8da7df7d9d
--- /dev/null
+++ b/dev-php/mod_php/files/digest-mod_php-4.3.1-r3
@@ -0,0 +1 @@
+MD5 bbfe584acb3549c62bb61355165e2ca6 php-4.3.1.tar.bz2 3682417
diff --git a/dev-php/mod_php/mod_php-4.3.1-r3.ebuild b/dev-php/mod_php/mod_php-4.3.1-r3.ebuild
new file mode 100644
index 000000000000..f16bd6b7af30
--- /dev/null
+++ b/dev-php/mod_php/mod_php-4.3.1-r3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.1-r3.ebuild,v 1.1 2003/04/23 10:04:57 robbat2 Exp $
+
+inherit php eutils
+
+IUSE="${IUSE} apache2"
+
+DESCRIPTION="Apache module for PHP"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa"
+SLOT="0"
+
+ # users have been having problems with compiling the gmp support... disabled for now
+ # - rphillips
+ #>=dev-libs/gmp-3.1.1
+
+DEPEND="${DEPEND}
+ || (
+ apache2? ( >=net-www/apache-2.0.43-r1 )
+ >=net-www/apache-1.3.26-r2
+ )
+ "
+
+RDEPEND="${RDEPEND}"
+
+src_compile() {
+ #no readline on server SAPI
+ myconf="${myconf} --without-readline "
+
+ # optional support for apache2
+ myconf="${myconf} --with-exec-dir=/usr/bin"
+ if [ "`use apache2`" ] ; then
+ myconf="${myconf} --with-apxs2=/usr/sbin/apxs2"
+ else
+ myconf="${myconf} --with-apxs=/usr/sbin/apxs"
+ fi
+
+ #this is an extra item required with mcrypt (which is include in the eclass) when used with apache
+ use crypt && myconf="${myconf} --disable-posix-threads"
+
+ myconf="${myconf} \
+ --enable-discard-path \
+ --enable-force-cgi-redirect \
+ --enable-mime-magic \
+ --enable-safe-mode \
+ --with-iconv"
+ php_src_compile
+}
+
+
+src_install() {
+ php_src_install
+
+ make INSTALL_ROOT=${D} install-pear install-headers install-programs install-build || die
+
+ cp php.ini-dist php.ini
+ insinto /etc/php4
+ doins php.ini
+ dosym /usr/lib/apache-extramodules /etc/php4/lib
+
+ if [ "`use apache2`" ] ; then
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/libphp4.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/70_mod_php.conf
+ dosym /etc/php4/php.ini /etc/apache2/conf/php.ini
+ else
+ exeinto /usr/lib/apache-extramodules
+ doexe .libs/libphp4.so
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_php.conf
+ dosym /etc/php4/php.ini /etc/apache/conf/php.ini
+ dosym /etc/php4/php.ini /etc/apache/conf/addon-modules/php.ini
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To have Apache run php programs, please do the following:"
+ if [ "`use apache2`" ] ; then
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PHP4\""
+ einfo
+ einfo "Please note Apache 2 support in php is currently experimental"
+ else
+ einfo "1. Execute the command:"
+ einfo " \"ebuild /var/db/pkg/dev-php/${PF}/${PF}.ebuild config\""
+ einfo "2. Edit /etc/conf.d/apache and add \"-D PHP\""
+ einfo
+ einfo "That will include the php mime types in your configuration"
+ einfo "automagically and setup Apache to load php when it starts."
+ fi
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libphp4.so mod_php4.c php4_module \
+ before=perl define=PHP4 addconf=conf/addon-modules/mod_php.conf
+ :;
+}
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index c368bf5c4722..b3fce404ecfd 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for dev-php/php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.41 2003/03/25 05:20:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.42 2003/04/23 10:04:32 robbat2 Exp $
+*php-4.3.1-r2 (22 Apr 2003)
+
+ 22 Apr 2003; Robin H. Johnson <robbat2@gentoo.org> php-4.3.1-r2.ebuild,
+ files/pear_config.diff:
+ New version utilizing PHP eclass
+ Masked still, very untested
+
*php-4.3.1-r1 (13 Jan 2003)
25 Mar 2003; Aron Griffis <agriffis@gentoo.org> php-4.3.1-r1.ebuild:
diff --git a/dev-php/php/Manifest b/dev-php/php/Manifest
index 40fc5fc643b0..fc13838b1f9a 100644
--- a/dev-php/php/Manifest
+++ b/dev-php/php/Manifest
@@ -1,12 +1,12 @@
MD5 2071da4985799320229b39c26c53940d php-4.3.1-r1.ebuild 8142
MD5 c06db8bbd5bb6030cc4f41c35a7bfc67 php-4.3.0-r4.ebuild 8032
-MD5 11c4333d2c040e0dc7291af8ba029611 php-4.3.1-r2.ebuild~ 2514
MD5 32e507e008f3a07bf40463b7e8b0d1fe php-4.3.0-r3.ebuild 6737
MD5 70c4aff8641931b5be8397696e68d520 php-4.3.1.ebuild 8189
-MD5 ea6305a2c210cfd80a60417c372b16ce php-4.3.1-r2.ebuild 2510
-MD5 939ff988c04fa4d9a6f39bc26e5899fb ChangeLog 6107
+MD5 132af40af8d5abc6238c3344b6d144f1 php-4.3.1-r2.ebuild 2509
+MD5 f66cf0479ac7418a6fec6487aeb32f9f ChangeLog 6301
MD5 3604218eee0ba5f7a1eac325de001eb1 files/digest-php-4.3.0-r3 63
MD5 3604218eee0ba5f7a1eac325de001eb1 files/digest-php-4.3.0-r4 63
MD5 316366d60770de4c45957483cde50fe8 files/digest-php-4.3.1-r1 63
MD5 316366d60770de4c45957483cde50fe8 files/digest-php-4.3.1-r2 63
+MD5 663577b8f4b90d61f245bb6052629194 files/pear_config.diff 422
MD5 316366d60770de4c45957483cde50fe8 files/digest-php-4.3.1 63
diff --git a/dev-php/php/files/digest-php-4.3.1-r2 b/dev-php/php/files/digest-php-4.3.1-r2
new file mode 100644
index 000000000000..da8da7df7d9d
--- /dev/null
+++ b/dev-php/php/files/digest-php-4.3.1-r2
@@ -0,0 +1 @@
+MD5 bbfe584acb3549c62bb61355165e2ca6 php-4.3.1.tar.bz2 3682417
diff --git a/dev-php/php/files/pear_config.diff b/dev-php/php/files/pear_config.diff
new file mode 100644
index 000000000000..57761db6ac4a
--- /dev/null
+++ b/dev-php/php/files/pear_config.diff
@@ -0,0 +1,12 @@
+--- pear/PEAR/Config.php 2002/12/22 01:43:20 1.35.2.2
++++ pear/PEAR/Config.php 2003/01/07 23:12:06 1.41
+
+@@ -142,7 +142,7 @@ if (isset($_ENV['PHP_PEAR_PREFERRED_STAT
+ if (isset($_ENV['PHP_PEAR_UMASK'])) {
+ define('PEAR_CONFIG_DEFAULT_UMASK', $_ENV['PHP_PEAR_UMASK']);
+ } else {
+- define('PEAR_CONFIG_DEFAULT_UMASK', umask());
++ define('PEAR_CONFIG_DEFAULT_UMASK', decoct(umask()));
+ }
+
+ // Default for cache_ttl
diff --git a/dev-php/php/php-4.3.1-r2.ebuild b/dev-php/php/php-4.3.1-r2.ebuild
new file mode 100644
index 000000000000..b07e160bf3de
--- /dev/null
+++ b/dev-php/php/php-4.3.1-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Update: Roman Weber <gentoo@gonzo.ch>
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.1-r2.ebuild,v 1.1 2003/04/23 10:04:33 robbat2 Exp $
+
+inherit php eutils
+
+IUSE="${IUSE} readline"
+
+DESCRIPTION="PHP Shell Interpreter"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="${DEPEND}
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 ) "
+
+RDEPEND="${RDEPEND}"
+
+src_compile() {
+
+ use readline && myconf="${myconf} --with-readline"
+
+
+ myconf="${myconf} \
+ --disable-cgi \
+ --enable-cli \
+ --enable-pcntl \
+ --with-pear"
+
+ php_src_compile
+
+}
+
+
+src_install() {
+ php_src_install
+
+ make INSTALL_ROOT=${D} install-cli install-pear install-headers install-programs install-modules install-build || die
+
+ # php executable is located in ./sapi/cli/
+ cp sapi/cli/php .
+ exeinto /usr/bin
+ doexe php
+
+ # Support for Java extension
+ #
+ # 1. install php_java.jar file into /etc/php4/lib directory
+ # 2. edit the php.ini file ready for installation
+ #
+ # - stuart@gnqs.org
+
+ if [ "`use java`" ] ; then
+
+ # we put these into /usr/lib so that they cannot conflict
+ # with other versions of PHP
+
+ insinto /usr/lib/php/extensions/no-debug-non-zts-20020429
+ doins ext/java/php_java.jar
+
+ cp ext/java/except.php java-test.php
+ doins java-test.php
+
+ JAVA_LIBRARY="`grep -- '-DJAVALIB' Makefile | sed -e 's/.\+-DJAVALIB=\"\([^"]*\)\".*$/\1/g;'`"
+ cat php.ini-dist | sed -e "s|;java.library .*$|java.library = $JAVA_LIBRARY|g;" > php.ini-1
+ cat php.ini-1 | sed -e "s|;java.class.path .*$|java.class.path = /etc/php4/lib/php_java.jar|g;" > php.ini-2
+ cat php.ini-2 | sed -e "s|extension_dir .*$|extension_dir = /etc/php4/lib|g;" > php.ini-3
+ cat php.ini-3 | sed -e "s|;extension=php_java.dll.*$|extension = java.so|g;" > php.ini-4
+ cat php.ini-4 | sed -e "s|;java.library.path .*$|java.library.path = /etc/php4/lib/|g;" > php.ini-5
+
+ mv php.ini-5 php.ini
+ else
+ mv php.ini-dist php.ini
+ fi
+
+ insinto /etc/php4
+ doins php.ini
+
+ if [ "`use java`" ]; then
+ # I can't find a way to make these symlinks using dosym
+ # SLH - 20030211
+ ( cd ${D}/usr/lib/php/extensions/no-debug-non-zts-20020429 ; ln -snf java.so libphp_java.so )
+ ( cd ${D}/etc/php4 ; ln -snf ../../usr/lib/php/extensions/no-debug-non-zts-20020429 lib )
+ fi
+
+}
+
+pkg_postinst() {
+ # This is more correct information.
+ einfo
+ einfo "This is a CLI only build."
+ einfo "You can not use it on a webserver."
+ einfo
+}