summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTal Peer <coredumb@gentoo.org>2003-08-02 22:31:04 +0000
committerTal Peer <coredumb@gentoo.org>2003-08-02 22:31:04 +0000
commit211ff007db2598c9a884ef2c42eef17610aa3c46 (patch)
treeae04449260a09d940836fa9ffa4978795f0cb120 /dev-php
parentFixed double installation of asp2php binary (once in /bin and once in /usr/bin). (diff)
downloadgentoo-2-211ff007db2598c9a884ef2c42eef17610aa3c46.tar.gz
gentoo-2-211ff007db2598c9a884ef2c42eef17610aa3c46.tar.bz2
gentoo-2-211ff007db2598c9a884ef2c42eef17610aa3c46.zip
Fixed double installation of asp2php binary (once in /bin and once in /usr/bin).
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/asp2php/ChangeLog8
-rw-r--r--dev-php/asp2php/Manifest4
-rw-r--r--dev-php/asp2php/asp2php-0.76.17-r1.ebuild31
-rw-r--r--dev-php/asp2php/files/asp2php-0.76.17-makefile.patch6
-rw-r--r--dev-php/asp2php/files/digest-asp2php-0.76.17-r11
5 files changed, 44 insertions, 6 deletions
diff --git a/dev-php/asp2php/ChangeLog b/dev-php/asp2php/ChangeLog
index 01646452310c..e7e2e94e30ea 100644
--- a/dev-php/asp2php/ChangeLog
+++ b/dev-php/asp2php/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/asp2php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/asp2php/ChangeLog,v 1.1 2003/08/02 20:50:46 coredumb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/asp2php/ChangeLog,v 1.2 2003/08/02 22:30:35 coredumb Exp $
+
+*asp2php-0.76.17-r1 (02 Aug 2003)
+
+ 02 Aug 2002; Tal Peer <coredumb@gentoo.rog> asp2php-0.76.17-r1.ebuild:
+ Fixed src_install's wrong behaviour - it installed the binary twice, once in
+ /bin and once in /usr/bin.
*asp2php-0.76.17 (02 Aug 2003)
diff --git a/dev-php/asp2php/Manifest b/dev-php/asp2php/Manifest
index 9ab8391c61ee..a0cbe6b281be 100644
--- a/dev-php/asp2php/Manifest
+++ b/dev-php/asp2php/Manifest
@@ -1,6 +1,6 @@
MD5 91b5a25be26689932adbc369b3d9a3b6 asp2php-0.76.17.ebuild 763
-MD5 973c87255e13854aad7c1a2168c95211 ChangeLog 404
-MD5 b8c4f4a8170576b04d2440b0e7092045 asp2php-0.76.17-r1.ebuild 748
+MD5 0da44aab703d2b7db4d9162428b0738f ChangeLog 622
+MD5 283f4ea57b94027e154a1206c6c4b731 asp2php-0.76.17-r1.ebuild 767
MD5 38ea19fda75342f889b9d9e54dd8e230 files/asp2php-0.76.17-makefile.patch 1249
MD5 a261c315bf4212c90600867a3bc18752 files/digest-asp2php-0.76.17 66
MD5 a261c315bf4212c90600867a3bc18752 files/digest-asp2php-0.76.17-r1 66
diff --git a/dev-php/asp2php/asp2php-0.76.17-r1.ebuild b/dev-php/asp2php/asp2php-0.76.17-r1.ebuild
new file mode 100644
index 000000000000..c973cf655656
--- /dev/null
+++ b/dev-php/asp2php/asp2php-0.76.17-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/asp2php/asp2php-0.76.17-r1.ebuild,v 1.1 2003/08/02 22:30:35 coredumb Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="ASP to PHP translator"
+SRC_URI="http://www.mikekohn.com/asp2php/${P}.tar.gz"
+HOMEPAGE="http://asp2php.naken.cc/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ epatch ${FILESDIR}/${P}-makefile.patch
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin
+ make DESTDIR="${D}" install || die
+
+ dodoc LICENSE README
+ docinto sample
+ dodoc sample/class_test.asp sample/filesystem.asp sample/mailer-test.asp sample/testfile.asp
+}
+
diff --git a/dev-php/asp2php/files/asp2php-0.76.17-makefile.patch b/dev-php/asp2php/files/asp2php-0.76.17-makefile.patch
index 9e6e68fc6975..b6187114826b 100644
--- a/dev-php/asp2php/files/asp2php-0.76.17-makefile.patch
+++ b/dev-php/asp2php/files/asp2php-0.76.17-makefile.patch
@@ -17,9 +17,9 @@
- @if [ -e gtkasp2php ]; then install gtkasp2php /usr/local/bin; fi;
- @echo "Compiled programs have been installed in /usr/local/bin"
+ @mkdir -p $(DESTDIR)/bin;
-+ @if [ -e asp2php ]; then install asp2php $(DESTDIR)/bin; fi;
-+ @if [ -e gtkasp2php ]; then install gtkasp2php $(DESTDIR)/bin; fi;
-+ @echo "Compiled programs have been installed in $(DESTDIR)/bin"
++ @if [ -e asp2php ]; then install asp2php $(DESTDIR)/usr/bin; fi;
++ @if [ -e gtkasp2php ]; then install gtkasp2php $(DESTDIR)/usr/bin; fi;
++ @echo "Compiled programs have been installed in $(DESTDIR)/usr/bin"
@echo ""
uninstall:
diff --git a/dev-php/asp2php/files/digest-asp2php-0.76.17-r1 b/dev-php/asp2php/files/digest-asp2php-0.76.17-r1
new file mode 100644
index 000000000000..e3f56eb18cfc
--- /dev/null
+++ b/dev-php/asp2php/files/digest-asp2php-0.76.17-r1
@@ -0,0 +1 @@
+MD5 c9ab4cf79d08605c1e0856ac81f414ef asp2php-0.76.17.tar.gz 53793