summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-10-21 19:39:25 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-10-21 19:39:25 +0000
commit183c68242c12ade3cca07416b4568c15c4ab961a (patch)
tree2c993667851b6da05f23c47ff907e0ea4b2a9014 /dev-php
parentWorked further on the 2.1.0 version bump: Added USE flags and dependencies to... (diff)
downloadgentoo-2-183c68242c12ade3cca07416b4568c15c4ab961a.tar.gz
gentoo-2-183c68242c12ade3cca07416b4568c15c4ab961a.tar.bz2
gentoo-2-183c68242c12ade3cca07416b4568c15c4ab961a.zip
Version bump. Bunch of security fixes
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/smarty/ChangeLog8
-rw-r--r--dev-php/smarty/smarty-2.6.28.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-php/smarty/ChangeLog b/dev-php/smarty/ChangeLog
index 2fe08d3f1720..7166069d77c7 100644
--- a/dev-php/smarty/ChangeLog
+++ b/dev-php/smarty/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/smarty
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.120 2013/10/09 17:09:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.121 2013/10/21 19:39:25 olemarkus Exp $
+
+*smarty-2.6.28 (21 Oct 2013)
+
+ 21 Oct 2013; Ole Markus With <olemarkus@gentoo.org> +smarty-2.6.28.ebuild,
+ smarty-2.6.27.ebuild:
+ Version bump. Bunch of security fixes
09 Oct 2013; Agostino Sarubbo <ago@gentoo.org> smarty-3.1.12.ebuild:
Stable for sparc, wrt bug #435618
diff --git a/dev-php/smarty/smarty-2.6.28.ebuild b/dev-php/smarty/smarty-2.6.28.ebuild
new file mode 100644
index 000000000000..7d47fe3b35ad
--- /dev/null
+++ b/dev-php/smarty/smarty-2.6.28.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.28.ebuild,v 1.1 2013/10/21 19:39:25 olemarkus Exp $
+
+EAPI=4
+
+inherit eutils
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_P="Smarty-${PV}"
+
+DESCRIPTION="A template engine for PHP."
+HOMEPAGE="http://www.smarty.net/"
+SRC_URI="http://www.smarty.net/files/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+PDEPEND="doc? ( =dev-php/smarty-docs-2* )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+ dodoc ${DOCS}
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "To use it in your scripts, either"
+ elog "1. define('SMARTY_DIR', \"/usr/share/php/${PN}/\") in your scripts, or"
+ elog "2. add '/usr/share/php/${PN}/' to the 'include_path' variable in your"
+ elog "php.ini file under /etc/php/*-php5.x"
+}