summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-04-06 18:45:06 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-04-06 18:45:06 +0000
commit02509cec30140fb7b1825251374ad777c9a3a31e (patch)
tree715f3d8258a0e7d5f69569380ab50987beca803b /dev-php
parentStable for amd64, wrt bug #410871 (diff)
downloadgentoo-2-02509cec30140fb7b1825251374ad777c9a3a31e.tar.gz
gentoo-2-02509cec30140fb7b1825251374ad777c9a3a31e.tar.bz2
gentoo-2-02509cec30140fb7b1825251374ad777c9a3a31e.zip
Version bump. RC that works with php 5.4
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug/ChangeLog7
-rw-r--r--dev-php/xdebug/xdebug-2.2.0_rc1.ebuild90
2 files changed, 96 insertions, 1 deletions
diff --git a/dev-php/xdebug/ChangeLog b/dev-php/xdebug/ChangeLog
index 52e4c92c5cc5..11159e592c61 100644
--- a/dev-php/xdebug/ChangeLog
+++ b/dev-php/xdebug/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/xdebug
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/ChangeLog,v 1.38 2012/03/13 13:20:26 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/ChangeLog,v 1.39 2012/04/06 18:45:06 olemarkus Exp $
+
+*xdebug-2.2.0_rc1 (06 Apr 2012)
+
+ 06 Apr 2012; Ole Markus With <olemarkus@gentoo.org> +xdebug-2.2.0_rc1.ebuild:
+ Version bump. RC that works with php 5.4
*xdebug-2.1.4 (13 Mar 2012)
diff --git a/dev-php/xdebug/xdebug-2.2.0_rc1.ebuild b/dev-php/xdebug/xdebug-2.2.0_rc1.ebuild
new file mode 100644
index 000000000000..1c5630d30ade
--- /dev/null
+++ b/dev-php/xdebug/xdebug-2.2.0_rc1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.2.0_rc1.ebuild,v 1.1 2012/04/06 18:45:06 olemarkus Exp $
+
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+
+EAPI="4"
+
+USE_PHP="php5-3 php5-4"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+inherit php-ext-source-r2
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+DEPEND="!dev-php/ZendOptimizer"
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+
+src_install() {
+ dodoc NEWS README CREDITS
+ php-ext-source-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "xdebug.auto_trace" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_format" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.trace_options" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_includes" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_params" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_return" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.collect_vars" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.default_enable" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.extended_info" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
+ php-ext-source-r2_addtoinifiles "xdebug.max_nesting_level" '"100"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_exception_trace" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_local_vars" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.show_mem_delta" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.ENV" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.FILES" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.GET" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.POST" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_globals" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_once" '"1"'
+ php-ext-source-r2_addtoinifiles "xdebug.dump_undefined" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_enable" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_append" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.profiler_aggregate" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_enable" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_handler" '"dbgp"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_host" '"localhost"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_mode" '"req"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_port" '"9000"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_autostart" '"0"'
+ php-ext-source-r2_addtoinifiles "xdebug.remote_log" '""'
+ php-ext-source-r2_addtoinifiles "xdebug.idekey" '""'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_data" '"512"'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_depth" '"2"'
+ php-ext-source-r2_addtoinifiles "xdebug.var_display_max_children" '"128"'
+
+}
+
+pkg_postinst() {
+ ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
+ ewarn "call xdebug_enable() in your code."
+}