summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-04-05 19:09:27 +0000
committerMatti Bickel <mabi@gentoo.org>2010-04-05 19:09:27 +0000
commit7397a38b8085d41977633e25aa8d39e7f8e60a3b (patch)
treedbbb3d7dbd463299db7d09e4e9ac3681a8fb2fff /dev-php5
parentStable on amd64 wrt bug #312177 (diff)
downloadgentoo-2-7397a38b8085d41977633e25aa8d39e7f8e60a3b.tar.gz
gentoo-2-7397a38b8085d41977633e25aa8d39e7f8e60a3b.tar.bz2
gentoo-2-7397a38b8085d41977633e25aa8d39e7f8e60a3b.zip
bump
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-http/ChangeLog9
-rw-r--r--dev-php5/pecl-http/pecl-http-1.6.6.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/dev-php5/pecl-http/ChangeLog b/dev-php5/pecl-http/ChangeLog
index f7e46d513ff2..fd467771d06c 100644
--- a/dev-php5/pecl-http/ChangeLog
+++ b/dev-php5/pecl-http/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/pecl-http
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/ChangeLog,v 1.11 2008/05/05 20:54:11 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/ChangeLog,v 1.12 2010/04/05 19:09:27 mabi Exp $
+
+*pecl-http-1.6.6 (05 Apr 2010)
+
+ 05 Apr 2010; <mabi@gentoo.org> +pecl-http-1.6.6.ebuild:
+ bump (bug #266977)
05 May 2008; Markus Meier <maekke@gentoo.org> pecl-http-1.6.0.ebuild:
amd64/x86 stable, bug #213566
diff --git a/dev-php5/pecl-http/pecl-http-1.6.6.ebuild b/dev-php5/pecl-http/pecl-http-1.6.6.ebuild
new file mode 100644
index 000000000000..77fb9317ef4b
--- /dev/null
+++ b/dev-php5/pecl-http/pecl-http-1.6.6.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/pecl-http-1.6.6.ebuild,v 1.1 2010/04/05 19:09:27 mabi Exp $
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="docs/examples/tutorial.txt ThanksTo.txt KnownIssues.txt"
+
+EAPI="2"
+
+inherit php-ext-pecl-r1 php-ext-base-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP."
+LICENSE="BSD-2 MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=net-misc/curl-7.19.4
+ sys-libs/zlib
+ dev-libs/libevent
+ >=dev-lang/php-5[hash,spl,session,iconv]
+ "
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ my_conf="--enable-http \
+ --with-http-curl-requests \
+ --with-http-zlib-compression \
+ --with-http-curl-libevent \
+ --with-http-magic-mime"
+
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+
+ php-ext-base-r1_addtoinifiles "http.etag.mode" "MD5"
+ php-ext-base-r1_addtoinifiles "http.force_exit" "1"
+ php-ext-base-r1_addtoinifiles "http.log.allowed_methods" ""
+ php-ext-base-r1_addtoinifiles "http.log.cache" ""
+ php-ext-base-r1_addtoinifiles "http.log.composite" ""
+ php-ext-base-r1_addtoinifiles "http.log.not_found" ""
+ php-ext-base-r1_addtoinifiles "http.log.redirect" ""
+ php-ext-base-r1_addtoinifiles "http.only_exceptions" "0"
+ php-ext-base-r1_addtoinifiles "http.persistent.handles.ident" "GLOBAL"
+ php-ext-base-r1_addtoinifiles "http.persistent.handles.limit" "-1"
+ php-ext-base-r1_addtoinifiles "http.request.datashare.connect" "0"
+ php-ext-base-r1_addtoinifiles "http.request.datashare.cookie" "0"
+ php-ext-base-r1_addtoinifiles "http.request.datashare.dns" "1"
+ php-ext-base-r1_addtoinifiles "http.request.datashare.ssl" "0"
+ php-ext-base-r1_addtoinifiles "http.request.methods.allowed" ""
+ php-ext-base-r1_addtoinifiles "http.request.methods.custom" ""
+ php-ext-base-r1_addtoinifiles "http.send.inflate.start_auto" "0"
+ php-ext-base-r1_addtoinifiles "http.send.inflate.start_flags" "0"
+ php-ext-base-r1_addtoinifiles "http.send.deflate.start_auto" "0"
+ php-ext-base-r1_addtoinifiles "http.send.deflate.start_flags" "0"
+ php-ext-base-r1_addtoinifiles "http.send.not_found_404" "1"
+}
+