summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-01-04 13:30:55 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-01-04 13:30:55 +0000
commit5084cfcadcd4ea6b223cc0edc8ae6f895716a84b (patch)
tree0b80e50ca917593f844e5b9037c893e4647e284b /dev-php5
parentVersion bump from project overlay (diff)
downloadgentoo-2-5084cfcadcd4ea6b223cc0edc8ae6f895716a84b.tar.gz
gentoo-2-5084cfcadcd4ea6b223cc0edc8ae6f895716a84b.tar.bz2
gentoo-2-5084cfcadcd4ea6b223cc0edc8ae6f895716a84b.zip
Version bump from project overlay
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/xcache/ChangeLog9
-rw-r--r--dev-php5/xcache/files/digest-xcache-1.2.23
-rw-r--r--dev-php5/xcache/xcache-1.2.2.ebuild77
3 files changed, 87 insertions, 2 deletions
diff --git a/dev-php5/xcache/ChangeLog b/dev-php5/xcache/ChangeLog
index a11a0aa64bbc..fa0e928a4e62 100644
--- a/dev-php5/xcache/ChangeLog
+++ b/dev-php5/xcache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/xcache
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/xcache/ChangeLog,v 1.12 2007/09/07 12:10:43 angelos Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xcache/ChangeLog,v 1.13 2008/01/04 13:30:54 jokey Exp $
+
+*xcache-1.2.2 (04 Jan 2008)
+
+ 04 Jan 2008; Markus Ullmann <jokey@gentoo.org> +xcache-1.2.2.ebuild:
+ Version bump from project overlay
07 Sep 2007; Christoph Mende <angelos@gentoo.org> xcache-1.2.1.ebuild:
Stable on amd64 wrt bug #189531
diff --git a/dev-php5/xcache/files/digest-xcache-1.2.2 b/dev-php5/xcache/files/digest-xcache-1.2.2
new file mode 100644
index 000000000000..adf8b16b0a0e
--- /dev/null
+++ b/dev-php5/xcache/files/digest-xcache-1.2.2
@@ -0,0 +1,3 @@
+MD5 0907f62536e6f8b10f900e54e37090b9 xcache-1.2.2.tar.bz2 210835
+RMD160 60a4f06f1fbac6ae33412fe9a1b317a05afbf095 xcache-1.2.2.tar.bz2 210835
+SHA256 2c37ad89627379a79e5f26e204ca4a61c2d13cd097161d78aa67a6881448786b xcache-1.2.2.tar.bz2 210835
diff --git a/dev-php5/xcache/xcache-1.2.2.ebuild b/dev-php5/xcache/xcache-1.2.2.ebuild
new file mode 100644
index 000000000000..4098863afc60
--- /dev/null
+++ b/dev-php5/xcache/xcache-1.2.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xcache/xcache-1.2.2.ebuild,v 1.1 2008/01/04 13:30:54 jokey Exp $
+
+PHP_EXT_NAME="xcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+PHPSAPILIST="apache2 cgi"
+
+inherit php-ext-source-r1 confutils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A fast and stable PHP opcode cacher"
+HOMEPAGE="http://xcache.lighttpd.net/"
+SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+# make test would just run php's test and as such need the full php source
+RESTRICT="test"
+
+DEPEND="!dev-php5/eaccelerator !dev-php5/pecl-apc !dev-php5/ZendOptimizer"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+ require_php_sapi_from cgi apache2
+}
+
+src_compile() {
+ has_php
+
+ my_conf="--enable-xcache=shared \
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ --enable-xcache-coverager \
+ --enable-xcache-assembler \
+ --enable-xcache-encoder \
+ --enable-xcache-decoder"
+
+ enable_extension_with_built_with =${PHP_PKG} apache2 apxs2 /usr/sbin/apxs2 "optimisation for apache2"
+
+ php-ext-source-r1_src_compile
+}
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc-php AUTHORS ChangeLog NEWS README THANKS
+
+ php-ext-base-r1_addtoinifiles "auto_globals_jit" '"0"'
+ php-ext-base-r1_addtoinifiles "xcache.cacher" '"1"'
+ php-ext-base-r1_addtoinifiles "xcache.size" '"10M"'
+ php-ext-base-r1_addtoinifiles "xcache.count" '"2"'
+ php-ext-base-r1_addtoinifiles "xcache.slots" '"8k"'
+ php-ext-base-r1_addtoinifiles "xcache.var_size" '"0"'
+ php-ext-base-r1_addtoinifiles "xcache.var_count" '"1"'
+ php-ext-base-r1_addtoinifiles "xcache.readonly_protection" '"0"'
+ php-ext-base-r1_addtoinifiles "xcache.mmap_path" '"/dev/zero"'
+ php-ext-base-r1_addtoinifiles "xcache.stat" '"1"'
+ php-ext-base-r1_addtoinifiles "xcache.coverager" '"0"'
+ php-ext-base-r1_addtoinifiles "xcache.coveragedump_directory" '""'
+ php-ext-base-r1_addtoinifiles "xcache.admin.enable_auth" '"1"'
+
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins Decompiler.class.php
+ insinto "${PHP_EXT_SHARED_DIR}/admin"
+ doins admin/*
+}
+
+pkg_postinst() {
+ elog "Decompiler.class.php and the admin/ directory shipped with this"
+ elog "release were installed into ${ROOT}usr/share/php5/xcache/."
+}