summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2008-06-03 03:33:55 +0000
committerLuca Longinotti <chtekk@gentoo.org>2008-06-03 03:33:55 +0000
commit765eb8d4e25adf63bab1ccb174f0c9bc04046ab2 (patch)
tree29e88e1cc0ab22c77afd246a016a3213f3af35bf /dev-php5/xdebug
parentVersion bump. (diff)
downloadgentoo-2-765eb8d4e25adf63bab1ccb174f0c9bc04046ab2.tar.gz
gentoo-2-765eb8d4e25adf63bab1ccb174f0c9bc04046ab2.tar.bz2
gentoo-2-765eb8d4e25adf63bab1ccb174f0c9bc04046ab2.zip
Version bump.
(Portage version: 2.2_pre7-r1/cvs/Linux 2.6.24-gentoo-r4 Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz)
Diffstat (limited to 'dev-php5/xdebug')
-rw-r--r--dev-php5/xdebug/ChangeLog7
-rw-r--r--dev-php5/xdebug/xdebug-2.0.3.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-php5/xdebug/ChangeLog b/dev-php5/xdebug/ChangeLog
index 1893f433efe6..d2ba3cb366c9 100644
--- a/dev-php5/xdebug/ChangeLog
+++ b/dev-php5/xdebug/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/xdebug
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/ChangeLog,v 1.21 2008/03/08 22:16:57 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/ChangeLog,v 1.22 2008/06/03 03:33:55 chtekk Exp $
+
+*xdebug-2.0.3 (03 Jun 2008)
+
+ 03 Jun 2008; Luca Longinotti <chtekk@gentoo.org> +xdebug-2.0.3.ebuild:
+ Version bump.
08 Mar 2008; <pva@gentoo.org> xdebug-2.0.2.ebuild:
amd64 stable, bug #208848.
diff --git a/dev-php5/xdebug/xdebug-2.0.3.ebuild b/dev-php5/xdebug/xdebug-2.0.3.ebuild
new file mode 100644
index 000000000000..9fdd5cfbf72a
--- /dev/null
+++ b/dev-php5/xdebug/xdebug-2.0.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/xdebug-2.0.3.ebuild,v 1.1 2008/06/03 03:33:55 chtekk Exp $
+
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+
+inherit php-ext-source-r1
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="A PHP Debugging and Profiling extension."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DEPEND="!dev-php5/ZendOptimizer"
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+
+need_php_by_category
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc-php NEWS README Changelog CREDITS LICENSE
+
+ php-ext-base-r1_addtoinifiles "xdebug.auto_trace" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_format" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_options" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_includes" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_params" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_return" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_vars" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.default_enable" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.extended_info" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
+ php-ext-base-r1_addtoinifiles "xdebug.max_nesting_level" '"100"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_exception_trace" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_local_vars" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_mem_delta" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.ENV" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.FILES" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.GET" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.POST" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_globals" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_once" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_undefined" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_enable" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_append" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_aggregate" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_enable" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_handler" '"dbgp"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_host" '"localhost"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_mode" '"req"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_port" '"9000"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_autostart" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_log" '""'
+ php-ext-base-r1_addtoinifiles "xdebug.idekey" '""'
+ php-ext-base-r1_addtoinifiles "xdebug.var_display_max_data" '"512"'
+ php-ext-base-r1_addtoinifiles "xdebug.var_display_max_depth" '"2"'
+ php-ext-base-r1_addtoinifiles "xdebug.var_display_max_children" '"128"'
+}