summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2006-10-09 07:08:34 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2006-10-09 07:08:34 +0000
commit9444790193998e81f01c4bebb555848859df91d7 (patch)
tree7415d17c4a11ac0938d26b51785b9694175dfd01 /dev-php5/xdebug/xdebug-2.0.0_rc1.ebuild
parentinputd bump with small patch from upstream (diff)
downloadgentoo-2-9444790193998e81f01c4bebb555848859df91d7.tar.gz
gentoo-2-9444790193998e81f01c4bebb555848859df91d7.tar.bz2
gentoo-2-9444790193998e81f01c4bebb555848859df91d7.zip
Version bump.
(Portage version: 2.1.2_pre2-r7)
Diffstat (limited to 'dev-php5/xdebug/xdebug-2.0.0_rc1.ebuild')
-rw-r--r--dev-php5/xdebug/xdebug-2.0.0_rc1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-php5/xdebug/xdebug-2.0.0_rc1.ebuild b/dev-php5/xdebug/xdebug-2.0.0_rc1.ebuild
new file mode 100644
index 000000000000..c2e60f0ae767
--- /dev/null
+++ b/dev-php5/xdebug/xdebug-2.0.0_rc1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/xdebug-2.0.0_rc1.ebuild,v 1.1 2006/10/09 07:08:34 sebastian Exp $
+
+PHP_EXT_ZENDEXT="yes"
+PHP_EXT_NAME="xdebug"
+
+inherit php-ext-source-r1
+
+IUSE=""
+DESCRIPTION="A PHP Debugging and Profiling extension."
+HOMEPAGE="http://www.xdebug.org/"
+SLOT="0"
+MY_P="${P/_/}"
+SRC_URI="http://pecl.php.net/get/${MY_P}.tgz"
+S="${WORKDIR}/xdebug-2.0.0RC1"
+LICENSE="Xdebug"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="${RDEPEND} !dev-php5/ZendOptimizer"
+
+need_php_by_category
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc-php NEWS README Changelog CREDITS LICENSE
+
+ php-ext-base-r1_addtoinifiles "xdebug.auto_trace" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_output_name" '"crc32"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_format" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_options" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_includes" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_params" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_return" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_vars" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.default_enable" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.extended_info" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
+ php-ext-base-r1_addtoinifiles "xdebug.max_nesting_level" '"100"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_exception_trace" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_local_vars" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_mem_delta" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.ENV" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.FILES" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.GET" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.POST" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_globals" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_once" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_undefined" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_enable" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_output_name" '"crc32"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_append" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_aggregate" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_enable" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_handler" '"dbgp"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_host" '"localhost"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_mode" '"req"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_port" '"9000"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_autostart" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_log" '""'
+ php-ext-base-r1_addtoinifiles "xdebug.allowed_clients" '""'
+ php-ext-base-r1_addtoinifiles "xdebug.idekey" '""'
+ php-ext-base-r1_addtoinifiles "xdebug.var_display_max_data" '"512"'
+ php-ext-base-r1_addtoinifiles "xdebug.var_display_max_depth" '"2"'
+}