summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-03-18 03:14:59 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-03-18 03:14:59 +0000
commit7a80f02a86e937ce4eafc7c82d545f9657fcb388 (patch)
tree378a6ab49c93a654309b4e5ba8316aaa9b0da550 /dev-php5/suhosin
parentFix DEPs. (diff)
downloadgentoo-2-7a80f02a86e937ce4eafc7c82d545f9657fcb388.tar.gz
gentoo-2-7a80f02a86e937ce4eafc7c82d545f9657fcb388.tar.bz2
gentoo-2-7a80f02a86e937ce4eafc7c82d545f9657fcb388.zip
Vbump.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-php5/suhosin')
-rw-r--r--dev-php5/suhosin/ChangeLog7
-rw-r--r--dev-php5/suhosin/files/digest-suhosin-0.9.183
-rw-r--r--dev-php5/suhosin/suhosin-0.9.18.ebuild39
3 files changed, 48 insertions, 1 deletions
diff --git a/dev-php5/suhosin/ChangeLog b/dev-php5/suhosin/ChangeLog
index 4eefc1f7a988..a404102fbd27 100644
--- a/dev-php5/suhosin/ChangeLog
+++ b/dev-php5/suhosin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/suhosin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/suhosin/ChangeLog,v 1.10 2007/03/10 23:09:53 yoswink Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/suhosin/ChangeLog,v 1.11 2007/03/18 03:14:58 chtekk Exp $
+
+*suhosin-0.9.18 (18 Mar 2007)
+
+ 18 Mar 2007; Luca Longinotti <chtekk@gentoo.org> +suhosin-0.9.18.ebuild:
+ Version bump, fix session module integration.
10 Mar 2007; Jose Luis Rivero <yoswink@gentoo.org> suhosin-0.9.17.ebuild:
Stable on alpha wrt security #153911
diff --git a/dev-php5/suhosin/files/digest-suhosin-0.9.18 b/dev-php5/suhosin/files/digest-suhosin-0.9.18
new file mode 100644
index 000000000000..80ff77eeabb2
--- /dev/null
+++ b/dev-php5/suhosin/files/digest-suhosin-0.9.18
@@ -0,0 +1,3 @@
+MD5 c9cc3ce1e07516346a3713fc658d74d2 suhosin-0.9.18.tgz 110421
+RMD160 65ac81383d881da0d827378bc3019e8c692313ac suhosin-0.9.18.tgz 110421
+SHA256 85e5f5af4ba6cbbe2e20a2cc2d808ea8f87bfcc4ded04c5ae2e5e257478d8131 suhosin-0.9.18.tgz 110421
diff --git a/dev-php5/suhosin/suhosin-0.9.18.ebuild b/dev-php5/suhosin/suhosin-0.9.18.ebuild
new file mode 100644
index 000000000000..395c780afda7
--- /dev/null
+++ b/dev-php5/suhosin/suhosin-0.9.18.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/suhosin/suhosin-0.9.18.ebuild,v 1.1 2007/03/18 03:14:58 chtekk Exp $
+
+PHP_EXT_NAME="suhosin"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-source-r1
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="Suhosin is an advanced protection system for PHP installations."
+HOMEPAGE="http://www.suhosin.org/"
+SRC_URI="http://www.hardened-php.net/suhosin/_media/${P}.tgz"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+ require_php_with_use unicode
+}
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc-php CREDITS
+
+ for inifile in ${PHPINIFILELIST} ; do
+ insinto "${inifile/${PHP_EXT_NAME}.ini/}"
+ insopts -m644
+ doins "suhosin.ini"
+ done
+}