summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-11-24 17:12:03 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-11-24 17:12:03 +0000
commitfab276b074336a020b49e8a1443d17e0dc309493 (patch)
tree616f0f318b219ecc5f7f7a22e3b5e53176d5c037 /dev-php5/phpunit
parentAdding myself to metadata as maintainer. (diff)
downloadgentoo-2-fab276b074336a020b49e8a1443d17e0dc309493.tar.gz
gentoo-2-fab276b074336a020b49e8a1443d17e0dc309493.tar.bz2
gentoo-2-fab276b074336a020b49e8a1443d17e0dc309493.zip
Version bump from the php overlay
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-php5/phpunit')
-rw-r--r--dev-php5/phpunit/ChangeLog10
-rw-r--r--dev-php5/phpunit/files/digest-phpunit-3.2.03
-rw-r--r--dev-php5/phpunit/phpunit-3.2.0.ebuild36
3 files changed, 48 insertions, 1 deletions
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index 783ceab129f2..da8b41c989a5 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/phpunit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.8 2007/10/28 12:04:19 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.9 2007/11/24 17:12:03 armin76 Exp $
+
+*phpunit-3.2.0 (24 Nov 2007)
+
+ 24 Nov 2007; Raúl Porcel <armin76@gentoo.org> +phpunit-3.2.0.ebuild:
+ Version bump from the php overlay
+
+ 22 Nov 2007; Jakub Moc <jakub@gentoo.org> +phpunit-3.2.0.ebuild:
+ Version bump
*phpunit-3.1.9 (28 Oct 2007)
diff --git a/dev-php5/phpunit/files/digest-phpunit-3.2.0 b/dev-php5/phpunit/files/digest-phpunit-3.2.0
new file mode 100644
index 000000000000..9d05419e8edd
--- /dev/null
+++ b/dev-php5/phpunit/files/digest-phpunit-3.2.0
@@ -0,0 +1,3 @@
+MD5 339466a741169f98271b88217fa288bf PHPUnit-3.2.0.tgz 194334
+RMD160 f2b79b278b4c2568bc6afcf963bbd5cd96e9c4b2 PHPUnit-3.2.0.tgz 194334
+SHA256 9eeda105e345acd8bdbecaee87d7efb8a2123aea9f836bad6d1b719803dc12b3 PHPUnit-3.2.0.tgz 194334
diff --git a/dev-php5/phpunit/phpunit-3.2.0.ebuild b/dev-php5/phpunit/phpunit-3.2.0.ebuild
new file mode 100644
index 000000000000..e8b114613440
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.2.0.ebuild,v 1.1 2007/11/24 17:12:03 armin76 Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Unit Testing framework for PHP 5."
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND="!dev-php4/phpunit"
+RDEPEND="${DEPEND}
+ !minimal? ( >=dev-php5/xdebug-2.0.0_rc2
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Testing_Selenium-0.2.0 )"
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+ require_php_with_use pcre reflection spl xml tokenizer
+}
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+}