summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-02-19 14:30:10 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-02-19 14:30:10 +0000
commitb253ef737884326148ca1dc9748481665e480dc3 (patch)
treeea08885ad47f5220d94cc1f8e705dbda484cf386 /dev-php5/phpunit
parentBump for #305635, fixed SRC_URI (diff)
downloadgentoo-2-b253ef737884326148ca1dc9748481665e480dc3.tar.gz
gentoo-2-b253ef737884326148ca1dc9748481665e480dc3.tar.bz2
gentoo-2-b253ef737884326148ca1dc9748481665e480dc3.zip
Added simplexml USE php flag check - required for XmlDataSet
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/phpunit')
-rw-r--r--dev-php5/phpunit/ChangeLog8
-rw-r--r--dev-php5/phpunit/phpunit-3.3.1-r1.ebuild35
-rw-r--r--dev-php5/phpunit/phpunit-3.4.6-r1.ebuild36
3 files changed, 78 insertions, 1 deletions
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index 205f2c8f941d..c1a2173346a2 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/phpunit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.23 2010/01/12 15:47:23 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.24 2010/02/19 14:30:10 reavertm Exp $
+
+*phpunit-3.3.1-r1 (19 Feb 2010)
+
+ 19 Feb 2010; Maciej Mrozowski <reavertm@gentoo.org>
+ +phpunit-3.3.1-r1.ebuild, +phpunit-3.4.6-r1.ebuild:
+ Added simplexml USE php flag check
12 Jan 2010; Christian Faulhammer <fauli@gentoo.org> phpunit-3.3.1.ebuild:
stable x86, bug 298994
diff --git a/dev-php5/phpunit/phpunit-3.3.1-r1.ebuild b/dev-php5/phpunit/phpunit-3.3.1-r1.ebuild
new file mode 100644
index 000000000000..171c6b4462d8
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.3.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.3.1-r1.ebuild,v 1.1 2010/02/19 14:30:10 reavertm Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~sparc ~x86"
+
+DESCRIPTION="Unit Testing framework for PHP 5."
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND="!dev-php4/phpunit"
+RDEPEND="${DEPEND}
+ !minimal? ( >=dev-php5/xdebug-2.0.0
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Testing_Selenium-0.2.0 )"
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_with_use pcre reflection simplexml spl xml tokenizer
+}
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+}
diff --git a/dev-php5/phpunit/phpunit-3.4.6-r1.ebuild b/dev-php5/phpunit/phpunit-3.4.6-r1.ebuild
new file mode 100644
index 000000000000..1b4e86b5fe6f
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.4.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.4.6-r1.ebuild,v 1.1 2010/02/19 14:30:10 reavertm Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~sparc ~x86"
+
+DESCRIPTION="Unit testing framework for PHP5"
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND="!dev-php4/phpunit
+ >=dev-php/PEAR-PEAR-1.8.1"
+RDEPEND="${DEPEND}
+ !minimal? ( >=dev-php5/xdebug-2.0.5
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Testing_Selenium-0.2.0 )"
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_with_use pcre reflection simplexml spl xml tokenizer
+}
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+}