summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-11-04 17:17:28 +0000
committerMatti Bickel <mabi@gentoo.org>2010-11-04 17:17:28 +0000
commit19f90ce07dcf5e83d3c95b810ed8c005fb54bf1c (patch)
tree2b4f2e054e08f52fb129b3fae1571c2d38b0f148 /dev-php5/phpdbg
parentstable x86, bug 343697 (diff)
downloadgentoo-2-19f90ce07dcf5e83d3c95b810ed8c005fb54bf1c.tar.gz
gentoo-2-19f90ce07dcf5e83d3c95b810ed8c005fb54bf1c.tar.bz2
gentoo-2-19f90ce07dcf5e83d3c95b810ed8c005fb54bf1c.zip
add version supporting minor version slotting
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/phpdbg')
-rw-r--r--dev-php5/phpdbg/ChangeLog7
-rw-r--r--dev-php5/phpdbg/phpdbg-2.15.5-r1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-php5/phpdbg/ChangeLog b/dev-php5/phpdbg/ChangeLog
index 85ae4084cbbd..a1cdd8b81ee2 100644
--- a/dev-php5/phpdbg/ChangeLog
+++ b/dev-php5/phpdbg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/phpdbg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/ChangeLog,v 1.12 2010/07/04 21:48:24 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/ChangeLog,v 1.13 2010/11/04 17:17:28 mabi Exp $
+
+*phpdbg-2.15.5-r1 (04 Nov 2010)
+
+ 04 Nov 2010; Matti Bickel <mabi@gentoo.org> +phpdbg-2.15.5-r1.ebuild:
+ add version supporting minor version slotting
04 Jul 2010; Matti Bickel <mabi@gentoo.org> phpdbg-2.15.5.ebuild:
does not build with php-5.3 (bug #324829)
diff --git a/dev-php5/phpdbg/phpdbg-2.15.5-r1.ebuild b/dev-php5/phpdbg/phpdbg-2.15.5-r1.ebuild
new file mode 100644
index 000000000000..d3a36d206b53
--- /dev/null
+++ b/dev-php5/phpdbg/phpdbg-2.15.5-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/phpdbg-2.15.5-r1.ebuild,v 1.1 2010/11/04 17:17:28 mabi Exp $
+
+EAPI=3
+
+PHP_EXT_NAME="dbg"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-source-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A PHP debugger useable with some editors like phpedit."
+HOMEPAGE="http://dd.cron.ru/dbg/"
+SRC_URI="mirror://sourceforge/dbg2/dbg-${PV}.tar.gz"
+LICENSE="dbgphp"
+SLOT="0"
+IUSE=""
+
+USE_PHP="php5-2"
+
+DEPEND="<dev-lang/php-5.3[-threads]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/dbg-${PV}"
+
+my_conf="--enable-dbg=shared --with-dbg-profiler"
+
+src_install() {
+ php-ext-source-r2_src_install
+ dodoc-php AUTHORS COPYING INSTALL
+
+ php-ext-base-r1_addtoinifiles "[Debugger]"
+ php-ext-base-r1_addtoinifiles "debugger.enabled" "on"
+ php-ext-base-r1_addtoinifiles "debugger.profiler_enabled" "on"
+}