summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2005-09-04 16:35:16 +0000
committerStuart Herbert <stuart@gentoo.org>2005-09-04 16:35:16 +0000
commit8f4c87dfa91f24e13d9644bd32f736b4ea2c15d8 (patch)
treeb75e81d1f47964cd015319fd12157e65ef54556a /dev-php5/pecl-pdo
parentInitial import for PHP5 (diff)
downloadgentoo-2-8f4c87dfa91f24e13d9644bd32f736b4ea2c15d8.tar.gz
gentoo-2-8f4c87dfa91f24e13d9644bd32f736b4ea2c15d8.tar.bz2
gentoo-2-8f4c87dfa91f24e13d9644bd32f736b4ea2c15d8.zip
Initial import for PHP5
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-php5/pecl-pdo')
-rw-r--r--dev-php5/pecl-pdo/ChangeLog7
-rw-r--r--dev-php5/pecl-pdo/Manifest5
-rw-r--r--dev-php5/pecl-pdo/files/digest-pecl-pdo-0.91
-rw-r--r--dev-php5/pecl-pdo/files/pdo_stmt.c.diff34
-rw-r--r--dev-php5/pecl-pdo/metadata.xml5
-rw-r--r--dev-php5/pecl-pdo/pecl-pdo-0.9.ebuild62
6 files changed, 114 insertions, 0 deletions
diff --git a/dev-php5/pecl-pdo/ChangeLog b/dev-php5/pecl-pdo/ChangeLog
new file mode 100644
index 000000000000..74ff08ad2def
--- /dev/null
+++ b/dev-php5/pecl-pdo/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-php5/pecl-pdo
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdo/ChangeLog,v 1.1 2005/09/04 16:32:39 stuart Exp $
+
+ 18 Aug 2005; <stuart@gentoo.org> ChangeLog:
+ Initial version; replaces older dev-php/* packages
+
diff --git a/dev-php5/pecl-pdo/Manifest b/dev-php5/pecl-pdo/Manifest
new file mode 100644
index 000000000000..bfb96bb4710c
--- /dev/null
+++ b/dev-php5/pecl-pdo/Manifest
@@ -0,0 +1,5 @@
+MD5 c58d07ca1c1235bbad9bccaec96fc062 metadata.xml 157
+MD5 73c4cda1625ca38616ed976dfa5e584f ChangeLog 218
+MD5 b7238b5def2a948fc3ad53a5b5d7ac5c pecl-pdo-0.9.ebuild 1472
+MD5 6279556cf34bf92200701c7a65f81ed9 files/digest-pecl-pdo-0.9 55
+MD5 c52b46703f8061eb524872fa24edc342 files/pdo_stmt.c.diff 915
diff --git a/dev-php5/pecl-pdo/files/digest-pecl-pdo-0.9 b/dev-php5/pecl-pdo/files/digest-pecl-pdo-0.9
new file mode 100644
index 000000000000..c1042eddf580
--- /dev/null
+++ b/dev-php5/pecl-pdo/files/digest-pecl-pdo-0.9
@@ -0,0 +1 @@
+MD5 21e8200b0245a2513399a6b7c382b765 PDO-0.9.tgz 46682
diff --git a/dev-php5/pecl-pdo/files/pdo_stmt.c.diff b/dev-php5/pecl-pdo/files/pdo_stmt.c.diff
new file mode 100644
index 000000000000..06f433c01e51
--- /dev/null
+++ b/dev-php5/pecl-pdo/files/pdo_stmt.c.diff
@@ -0,0 +1,34 @@
+--- pdo_stmt.c 2005-07-27 04:06:11.000000000 +0200
++++ pdo_stmt.c 2005-08-06 20:50:17.000000000 +0200
+@@ -18,7 +18,7 @@
+ +----------------------------------------------------------------------+
+ */
+
+-/* $Id: pdo_stmt.c,v 1.116 2005/07/22 14:31:20 helly Exp $ */
++/* $Id: pdo_stmt.c,v 1.118 2005/08/03 18:26:16 iliaa Exp $ */
+
+ /* The PDO Statement Handle Class */
+
+@@ -1985,12 +1985,20 @@
+ struct pdo_column_data *cols = stmt->columns;
+
+ for (i = 0; i < stmt->column_count; i++) {
+- efree(cols[i].name);
++ if (cols[i].name) {
++ efree(cols[i].name);
++ cols[i].name = NULL;
++ }
+ }
+ efree(stmt->columns);
++ stmt->columns = NULL;
++ }
++
++ if (stmt->fetch.into && stmt->default_fetch_type == PDO_FETCH_INTO) {
++ FREE_ZVAL(stmt->fetch.into);
++ stmt->fetch.into = NULL;
+ }
+
+-
+ do_fetch_opt_finish(stmt, 1 TSRMLS_CC);
+
+ zend_objects_store_del_ref(&stmt->database_object_handle TSRMLS_CC);
diff --git a/dev-php5/pecl-pdo/metadata.xml b/dev-php5/pecl-pdo/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php5/pecl-pdo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php5/pecl-pdo/pecl-pdo-0.9.ebuild b/dev-php5/pecl-pdo/pecl-pdo-0.9.ebuild
new file mode 100644
index 000000000000..97d2a4e7715b
--- /dev/null
+++ b/dev-php5/pecl-pdo/pecl-pdo-0.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdo/pecl-pdo-0.9.ebuild,v 1.1 2005/09/04 16:32:39 stuart Exp $
+
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_PECL_PKG="PDO"
+PHP_EXT_NAME="pdo"
+PHP_EXT_INI="yes"
+
+inherit php-ext-pecl-r1
+
+IUSE="firebird mssql mysql oci8 odbc postgres sqlite"
+DESCRIPTION="Core PHP Data Objects (PDO)"
+SLOT="0"
+LICENSE="PHP"
+KEYWORDS="~ppc ~x86"
+DEPEND="${DEPEND}"
+PDEPEND="${PDEPEND}
+ firebird? ( dev-php5/pecl-pdo-firebird )
+ mssql? ( dev-php5/pecl-pdo-dblib )
+ mysql? ( dev-php5/pecl-pdo-mysql )
+ oci8? ( dev-php5/pecl-pdo-oci )
+ odbc? ( dev-php5/pecl-pdo-odbc )
+ postgres? ( dev-php5/pecl-pdo-pgsql )
+ sqlite? ( dev-php5/pecl-pdo-sqlite )"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+
+ # if the user has compiled in PDO, he can't use this package
+ if built_with_use =${PHP_PKG} pdo ; then
+ eerror
+ eerror "You have built ${PHP_PKG} to use the bundled PDO support."
+ eerror "If you want to use the PECL PDO packages, you must rebuild"
+ eerror "your PHP with the 'pdo-external' USE flag instead."
+ eerror
+ die "PHP built to use bundled PDO support"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Patches the file to the newest CVS sources
+ epatch ${FILESDIR}/pdo_stmt.c.diff
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+
+ # install missing header files
+ destdir=/usr/$(get_libdir)/php5
+ dodir ${destdir}/include/php/ext/pdo
+ insinto ${destdir}/include/php/ext/pdo
+ doins php_pdo_driver.h
+ doins php_pdo.h
+ doins php_pdo_int.h
+}